您的位置:首页 > 其它

poj 2104 K-th Number

2016-03-28 19:46 302 查看
K-th Number

Time Limit: 20000MSMemory Limit: 65536K
Total Submissions: 45708Accepted: 15198
Case Time Limit: 2000MS
Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1...n] of different integer numbers, your program must answer a series of questions Q(i, j, k) in the form: "What would be the k-th number in a[i...j] segment, if this segment was sorted?"
For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort this segment, we get (2, 3, 5, 6), the third number is 5, and therefore the answer to the question is 5.
Input

The first line of the input file contains n --- the size of the array, and m --- the number of questions to answer (1 <= n <= 100 000, 1 <= m <= 5 000).
The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given.
The following m lines contain question descriptions, each description consists of three numbers: i, j, and k (1 <= i <= j <= n, 1 <= k <= j - i + 1) and represents the question Q(i, j, k).
Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.
Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

题意:一组数,找出所给的i到j之间第k大的数;
题解:要用到划分树,但是不会。           然后  这样排序也可以!!!!可能是时间复杂度不高吧!一直用sort排序(时间复杂度为nlogn)的话,时间复杂度很大


#include<stdio.h>
#include<string.h>
#include<cstdio>
#include<string>
#include<math.h>
#include<algorithm>
#define LL long long
#define PI atan(1.0)*4
#define DD double
#define MAX 110000
#define mod 100
#define dian 1.000000011
#define INF 0x3f3f3f
using namespace std;
struct node
{
int x;
int id;
}s[MAX];
bool cmp(node a,node b)
{
return a.x<b.x;
}
int main()
{
int n,m,j,i,t,k;
int a,b,c;
while(scanf("%d%d",&n,&m)!=EOF)
{
for(i=1;i<=n;i++)
{
scanf("%d",&s[i].x);
s[i].id=i;
}
sort(s+1,s+n+1,cmp);
while(m--)
{
scanf("%d%d%d",&a,&b,&c);
for(i=1;i<=n;i++)
{
if(s[i].id>=a&&s[i].id<=b)
c--;
if(c==0) break;
}
printf("%d\n",s[i].x);
}
}
return 0;
}


  
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: