您的位置:首页 > 其它

hdu 1260 Tickets (dp)

2016-03-28 19:43 351 查看
http://acm.hdu.edu.cn/showproblem.php?pid=1260


Tickets

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2538    Accepted Submission(s): 1236


Problem Description

Jesus, what a great movie! Thousands of people are rushing to the cinema. However, this is really a tuff time for Joe who sells the film tickets. He is wandering when could he go back home as early as possible.

A good approach, reducing the total time of tickets selling, is let adjacent people buy tickets together. As the restriction of the Ticket Seller Machine, Joe can sell a single ticket or two adjacent tickets at a time.

Since you are the great JESUS, you know exactly how much time needed for every person to buy a single ticket or two tickets for him/her. Could you so kind to tell poor Joe at what time could he go back home as early as possible? If so, I guess Joe would full
of appreciation for your help.

 

Input

There are N(1<=N<=10) different scenarios, each scenario consists of 3 lines:

1) An integer K(1<=K<=2000) representing the total number of people;

2) K integer numbers(0s<=Si<=25s) representing the time consumed to buy a ticket for each person;

3) (K-1) integer numbers(0s<=Di<=50s) representing the time needed for two adjacent people to buy two tickets together.

 

Output

For every scenario, please tell Joe at what time could he go back home as early as possible. Every day Joe started his work at 08:00:00 am. The format of time is HH:MM:SS am|pm.

 

Sample Input

2
2
20 25
40
1
8

 

Sample Output

08:00:40 am
08:00:08 am

 

题目大意:N组测试数据,k个人排队买票,第一行输入k个数,表示每个人买票需要花费的时间,第二行输入k-1个数,表示第i-1人和第i个人一块买票的时间,计算所有人买完票需要的最小时间

递推式:dp[i] = min (b[i] + dp[i-2], dp[i-1] + a[i]);

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <queue>
#include <algorithm>

using namespace std;

#define N 3000
#define INF 0x3f3f3f3f
#define MOD 2009
#define met(a, b) memset (a, b, sizeof(a))

typedef long long LL;

int main ()
{
int t, n, a
, b
, dp
;
scanf ("%d", &t);

while (t--)
{
met (a, 0);
met (b, 0);
scanf ("%d", &n);
for (int i=1; i<=n; i++)
{
scanf ("%d", &a[i]);
dp[i] = 0;
}
for (int i=2; i<=n; i++)
scanf ("%d", &b[i]);

dp[1] = a[1];
int k = 0;
for (int i=2; i<=n; i++)
{
dp[i] = min (b[i] + dp[i-2], dp[i-1] + a[i]);
}

int h = dp
/ 3600;
dp
%= 3600;
int m = dp
/ 60;
dp
%= 60;
int s = dp
;

int flag = 0;

if (h + 8 >= 12)
flag = 1;

h = (h + 8) % 12;
if (h == 0) h = 12;

printf ("%02d:%02d:%02d ", h, m, s);
if (flag) puts ("pm");
else puts ("am");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: