您的位置:首页 > 其它

PAT (Advanced Level) Practise 1097 Deduplication on a Linked List (25)

2016-03-25 21:12 447 查看


1097. Deduplication on a Linked List (25)

时间限制

300 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean
time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (<= 105) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer,
and NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 104, and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:
00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output:
00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

去重,把去掉的部分放到另外一个链表里。
#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
typedef long long LL;
const int maxn =1e5 + 10;
int n,s,f[maxn],nt[maxn],key[maxn],x,y,z,a,b,aa,bb;

int main()
{
scanf("%d%d", &s,&n);
while (n--)
{
scanf("%d%d%d",&x,&y,&z);
key[x]=y; nt[x]=z;
}
a=b=-1; aa=bb=-1;
for (int i=s;i!=-1;i=nt[i])
{
if (f[abs(key[i])])
{
if (b==-1) b=bb=i;
else bb=nt[bb]=i;
}
else
{
f[abs(key[i])]=1;
if (a==-1) a=aa=i;
else aa=nt[aa]=i;
}
}
nt[aa]=-1;
for (int i=a;i!=-1;i=nt[i])
{
printf("%05d %d ",i,key[i]);
if (nt[i]==-1) printf("-1\n");
else printf("%05d\n",nt[i]);
}
if (b!=-1) nt[bb]=-1;
for (int i=b;i!=-1;i=nt[i])
{
printf("%05d %d ",i,key[i]);
if (nt[i]==-1) printf("-1\n");
else printf("%05d\n",nt[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  PAT