您的位置:首页 > 产品设计 > UI/UE

Number Sequence (HDU_1711) KMP

2016-03-16 19:03 393 查看


Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 18276    Accepted Submission(s): 7985


Problem Description

Given two sequences of numbers : a[1], a[2], ...... , a
, and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one
K exist, output the smallest one.

 

Input

The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a
.
The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].

 

Output

For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.

 

Sample Input

2
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 1 3
13 5
1 2 1 2 3 1 2 3 1 3 2 1 2
1 2 3 2 1

 

Sample Output

6
-1

 

题目大意:数字序列匹配。

解题思路:KMP.

代码如下:

#include"iostream"
#include"cstdio"
using namespace std;
const int maxn = 1000005;
const int maxm = 10005;
int s[maxn],p[maxm],Next[maxm];
void MakeNext(int m){
Next[0] = -1;
int i = 0,j = -1;
//i表示主串的指针,j表示模式串的指针
while(i < m){//i不回溯,不断向后移动
if(j == -1 || p[i] == p[j]){
i ++ , j ++; //两串当前位置相等,比较下一位
if(p[i] != p[j]) Next[i] = j;
else Next[i] = Next[j];
}
else j = Next[j];
}
}
int KMP(int n,int m){
int i = 0,j = 0;
while(i < n && j < m){
if(s[i] == p[j] || j == -1)
i ++,j ++;
else j = Next[j];
}
if(j == m) return i - m + 1;
else return -1;
}
int main(){
int n,m,cas;
scanf("%d",&cas);
while(cas --){
scanf("%d%d",&n,&m);
for(int i = 0;i < n;i ++)
scanf("%d",&s[i]);
for(int i = 0;i < m;i ++)
scanf("%d",&p[i]);
if(m > n) printf("-1\n");
else{
MakeNext(m);
printf("%d\n",KMP(n,m));
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: