您的位置:首页 > 其它

Simpsons’ Hidden Talents (HDU_2594) KMP

2016-03-22 21:32 363 查看


Simpsons’ Hidden Talents

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 5427    Accepted Submission(s): 1963


Problem Description

Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.

Marge: Yeah, what is it?

Homer: Take me for example. I want to find out if I have a talent in politics, OK?

Marge: OK.

Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix

in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton

Marge: Why on earth choose the longest prefix that is a suffix???

Homer: Well, our talents are deeply hidden within ourselves, Marge.

Marge: So how close are you?

Homer: 0!

Marge: I’m not surprised.

Homer: But you know, you must have some real math talent hidden deep in you.

Marge: How come?

Homer: Riemann and Marjorie gives 3!!!

Marge: Who the heck is Riemann?

Homer: Never mind.

Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.

 

Input

Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.

 

Output

Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.

The lengths of s1 and s2 will be at most 50000.

 

Sample Input

clinton
homer
riemann
marjorie

 

Sample Output

0
rie 3

题目大意:给出两端字符串,区第一段字符串的前缀和第二段字符串的后缀,求问两者相同的话最长为多少。

解题思路:问题转换为问第二段字符最多能够匹配第一段字符串多少个字符。

代码如下:

#include"iostream"
#include"cstdio"
#include"cstring"
using namespace std;
const int maxn = 50005;
int Next[maxn];
char s[maxn],p[maxn],ans[maxn];
void MakeNext(int len){
Next[0] = -1;
int i = 0,j = -1;
while(i < len){
if(j == -1 || p[i] == p[j])
Next[++i] = ++j;
else j = Next[j];
}
}
int KMP(int n,int m){
int i = 0,j = 0;
while(i < n){
if(j == -1 || s[i] == p[j]){
i ++,j ++;
if(i == n) return j;
if(j == m) j = Next[j];
}
else j = Next[j];
}
}
int main(){
int n,m;
while(scanf("%s%s",p,s) != EOF){
m = strlen(p);
n = strlen(s);
MakeNext(m);
int num = KMP(n,m);
if(num == 0) printf("0\n");
else{
memset(ans,'\0',sizeof(ans));
strncpy(ans,p,num);
printf("%s %d\n",ans,num);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  KMP