您的位置:首页 > 其它

2016SDAU课程练习一1016Q

2016-03-15 23:03 239 查看
Problem Q
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 22   Accepted Submission(s) : 9
[align=left]Problem Description[/align]
FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less.

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
 

[align=left]Input[/align]
* Line 1: A single integer N< br>< br>* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
 

[align=left]Output[/align]
* Line 1: A single integer that is the median milk output.
 

[align=left]Sample Input[/align]

5
2
4
1
3
5

 

[align=left]Sample Output[/align]

3

fj是测量他的羊群寻找最牛平均。他想知道牛奶的“中值”:有一半的奶牛给比中位数更给多或少一半。

给定一个奇数奶牛N(1 <= N < 10000)和产奶量(1。1000000),发现牛奶中的金额,至少一半的奶牛给牛奶或更多相同的量至少有一半给相同或更少。
输入
一个整数n

每行包含一个整数,是一头奶牛的牛奶产量。
输出
一个整数,平均产奶量。
 
水题一道,排序,求中位数。没考虑偶数情况,尝试一下,没想到成功了。
一个字:爽!
ac代码:
#include<iostream>

#include<cstdio>

#include<cstring>

#include<cmath>

#include<set>

#include <algorithm>

using namespace std;

int cow[10001];

int main(){

    int n;

    cin>>n;

    for(int i=0;i<n;i++){

        cin>>cow[i];

    }

    sort(cow,cow+n);

    cout<<cow[n/2]<<endl;

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: