您的位置:首页 > 其它

2016SDAU课程练习一1012 Problem M

2016-03-21 21:29 162 查看
Problem M
Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 60000/30000K (Java/Other)
Total Submission(s) : 50   Accepted Submission(s) : 27
[align=left]Problem Description[/align]
Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers among these primes. Work in this area has resulted in the practical use of results from number theory and other branches
of mathematics once considered to be only of theoretical interest.

This problem involves the efficient computation of integer roots of numbers.

Given an integer n>=1 and an integer p>= 1 you have to write a program that determines the n th positive root of p. In this problem, given such integers n and p, p will always be of the form k to the nth. power,
for an integer k (this integer is what your program must find).
 

[align=left]Input[/align]
The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<= 200, 1<=p<10<sup>101</sup> and there exists an integer k, 1<=k<=10<sup>9</sup> such that k<sup>n</sup> = p.

 

[align=left]Output[/align]
For each integer pair n and p the value k should be printed, i.e., the number k such that k n =p.

 

[align=left]Sample Input[/align]

2 16
3 27
7 4357186184021382204544

 

[align=left]Sample Output[/align]

4
3
1234

没啥好说的了,本来还想用模拟,想想不会干脆用常规方法做了,结果ac了。。。
还有无限循环。。。
到网上找了一下几个数据类型的范围分享一下:
类型            长度 (bit)           有效数字                   绝对值范围
    float            32                     6~7                 10^(-37) ~ 10^38

    double         64                    15~16              10^(-307) ~10^308

    long double  128                  18~19               10^(-4931) ~ 10 ^ 4932

ac代码:
#include<iostream>

#include<cstdio>

#include<cstring>

#include<cmath>

#include<set>

#include<algorithm>

using namespace std;

int main(){

 int n;

 double p;

 while(cin>>n){

  cin>>p;

  cout<<pow(p,1.0/n)<<endl;

 }

 return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: