您的位置:首页 > 其它

poj 1742 Coins (动态规划,背包问题)

2016-03-13 15:47 399 查看
Coins

Time Limit: 3000MSMemory Limit: 30000K
Total Submissions: 32977Accepted: 11208
Description

People in Silverland use coins.They have coins of value A1,A2,A3...An Silverland dollar.One day Tony opened his money-box and found there were some coins.He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3...An and
C1,C2,C3...Cn corresponding to the number of Tony's coins of value
A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay
use these coins.

Input

The
input contains several test cases. The first line of each test case
contains two integers n(1<=n<=100),m(m<=100000).The second line
contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn
(1<=Ai<=100000,1<=Ci<=1000). The last test case is followed
by two zeros.
Output

For each test case output the answer on a single line.
Sample Input

3 10
1 2 4 2 1 1
2 5
1 4 2 1
0 0

Sample Output

8
4

题目大意:有n种面值分别为A[1],A[2],...,A
的硬币,硬币的个数分别为c[1],c[2],...,c
,问这些硬币能凑出多少种m以下(包括m)的数
这是我去年比赛时遇到的第一道题,现在才明白,这是一道多重背包问题,下面是我的ac代码:


#include<iostream>
#include<string.h>
using namespace std;
int dp[100010],sum[110000];
int m,n,a[110],c[110];
int main(){
while(cin>>n>>m&&n+m){
for(int i=1;i<=n;i++) cin>>a[i];
for(int i=1;i<=n;i++) cin>>c[i];
memset(dp,0,sizeof(dp));
dp[0]=1;
int ans=0;
for(int i=1;i<=n;i++){
memset(sum,0,sizeof(sum));
for(int j=a[i];j<=m;j++){
if(!dp[j]&&dp[j-a[i]]&&sum[j-a[i]]<c[i]){
dp[j]=1;
sum[j]=sum[j-a[i]]+1;
ans++;
}
}
}
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: