您的位置:首页 > 大数据 > 人工智能

HUST 1606 - Naive

2016-03-09 09:25 471 查看
1606 - Naive

时间限制:3秒 内存限制:128兆

779 次提交 138 次通过

题目描述

Give you a positive integer x, determine whether it is the sum of three positive cubic numbers.

输入

There’re several test cases. For each case:

Only one line containing an integer x (1≤x≤10^6)

输出

For each test case, print “Yes” if it is or “No” if it isn’t.

(See sample for more details)

样例输入

1

3

10

样例输出

No

Yes

Yes、

#include <iostream>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <math.h>
#include <stdio.h>

using namespace std;
int a[100005];
int b[1000005];
int cot;
void init()
{
cot=0;
for(int i=1;i<=200;i++)
{
if(i*i*i<=1000000)
a[cot++]=i*i*i;
else
break;
}
}
void init2()
{
int cnt=0;
for(int i=0;i<cot;i++)
{
for(int j=0;j<cot;j++)
{
for(int k=0;k<cot;k++)
{
if(a[i]+a[j]+a[k]<=1000000)
b[a[i]+a[j]+a[k]]=1;
}

}

}

}
int main()
{
int n;
init();

init2();
while(scanf("%d",&n)!=EOF)
{

if(b
)
printf("Yes\n");
else
printf("No\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: