您的位置:首页 > 大数据 > 人工智能

集训队专题(8)1007 Remainder

2016-03-08 20:55 411 查看


Remainder

Time Limit: 6000/3000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 3625 Accepted Submission(s): 846



Problem Description

Coco is a clever boy, who is good at mathematics. However, he is puzzled by a difficult mathematics problem. The problem is: Given three integers N, K and M, N may adds (‘+’) M, subtract (‘-‘) M, multiples (‘*’) M or modulus (‘%’) M (The definition of ‘%’ is
given below), and the result will be restored in N. Continue the process above, can you make a situation that “[(the initial value of N) + 1] % K” is equal to “(the current value of N) % K”? If you can, find the minimum steps and what you should do in each
step. Please help poor Coco to solve this problem.

You should know that if a = b * q + r (q > 0 and 0 <= r < q), then we have a % q = r.

Input

There are multiple cases. Each case contains three integers N, K and M (-1000 <= N <= 1000, 1 < K <= 1000, 0 < M <= 1000) in a single line.

The input is terminated with three 0s. This test case is not to be processed.

Output

For each case, if there is no solution, just print 0. Otherwise, on the first line of the output print the minimum number of steps to make “[(the initial value of N) + 1] % K” is equal to “(the final value of N) % K”. The second line print the operations to
do in each step, which consist of ‘+’, ‘-‘, ‘*’ and ‘%’. If there are more than one solution, print the minimum one. (Here we define ‘+’ < ‘-‘ < ‘*’ < ‘%’. And if A = a1a2...ak and B = b1b2...bk are both solutions, we say A < B, if and only if there exists
a P such that for i = 1, ..., P-1, ai = bi, and for i = P, ai < bi)

Sample Input

2 2 2
-1 12 10
0 0 0


Sample Output

0
2
*+


Author

Wang Yijie

这题的思路也很简单,只要通过四钟运算方法得到答案,唯一需要注意的就是由于减法可能会造成取余的结果为负数,所以我们还是在取余的时候采取((a%n)+n)%n的形式避免这种情况,其他关于对余数的把控也就是对结果是否为0的情况判定和我在上一题1006 Yet Another Multiple Problem中的讲解时一样的。

#include <cstdio>
#include <cstring>
#include <queue>
#include <algorithm>
using namespace std;
const int maxn = 1e6+10;
char action[5] = "+-*%";
int vis[maxn],c[maxn];
int mod,n,k,m;
struct node
{
int from,w;
}edge[maxn];
void print(int p,int step)
{
if(edge[p].from == -1)
{
printf("%d\n",step);
return ;
}
print(edge[p].from,step+1);
printf("%c",action[edge[p].w]);
}
void bfs()
{
memset(vis,0,sizeof(vis));
int i,j,p,ans,b,d,u,v;
for(i=0; i<mod; i++) edge[i].from = -1;
queue<int> q;
ans = ((n+1)%k+k)%k;
p = (n%mod + mod)%mod;
vis[p] = 1;
q.push(p);
while(!q.empty())
{
p = q.front();
q.pop();
if(p%k == ans)
{
print(p,0);
printf("\n");
return ;
}
for(i=0; i<4; i++)
{
if(i == 0) v = (p+m)%mod;
else if(i == 1) v = ((p-m)%mod+mod)%mod;
else if(i == 2) v = (p*m)%mod;
else v = p%m;
if(vis[v]) continue;
vis[v] = 1;
edge[v].from = p;
edge[v].w = i;
q.push(v);
}
}
printf("0\n");
}
int main()
{
while(scanf("%d%d%d",&n,&k,&m),n||m||k)
{
mod = m*k;
bfs();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: