您的位置:首页 > 其它

poj 3660 Cow Contest

2016-03-06 16:27 309 查看
Cow Contest

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 8987Accepted: 5046
Description

N (1 ≤ N ≤ 100) cows, conveniently numbered 1..N, are participating in a programming contest. As we all know, some cows code better than others. Each cow has a certain constant skill rating that is unique among the competitors.

The contest is conducted in several head-to-head rounds, each between two cows. If cow A has a greater skill level than cow B (1 ≤ A ≤ N; 1 ≤ B ≤ N; A ≠ B), then cow A will always beat cow B.

Farmer John is trying to rank the cows by skill level. Given a list the results of M (1 ≤ M ≤ 4,500) two-cow rounds, determine the number of cows whose ranks can be precisely determined from the results. It is guaranteed that the results of the rounds will not be contradictory.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Each line contains two space-separated integers that describe the competitors and results (the first integer, A, is the winner) of a single round of competition: A and B

Output

* Line 1: A single integer representing the number of cows whose ranks can be determined
 

Sample Input

5 5
4 3
4 2
3 2
1 2
2 5

Sample Output

2

可以说得上是最短路吧,反正我会是用弗洛伊德暴力水过的,代码很简单,思路清晰就好。

题意:牛之间有绝对的强弱,给出一些胜负关系,问有多少头牛可以确定其绝对排名。

附上代码:

#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
int main()
{
int n,m,i,j,k;
while(~scanf("%d%d",&n,&m))
{
int a,b,map[105][105],t;
memset(map,0,sizeof(map));
for(i=1; i<=m; i++)
{
scanf("%d%d",&a,&b);
map[a][b]=1;
}
for(i=1; i<=n; i++)
for(j=1; j<=n; j++)
for(k=1; k<=n; k++)
if(map[j][i]&&map[i][k])  //暴力弗洛伊德,所有的关系连成图
map[j][k]=1;
int ans=0;
for(i=1; i<=n; i++)
{
int t=0;
for(j=1; j<=n; j++)
t+=map[i][j]+map[j][i];
if(t==n-1)
ans++;
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: