您的位置:首页 > 其它

#HDU 2647 Reward 【拓扑排序】

2016-03-02 11:33 204 查看

题目:


Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 6614    Accepted Submission(s): 2037


Problem Description

Dandelion's uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.

The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a's reward should more than b's.Dandelion's unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work's reward
will be at least 888 , because it's a lucky number.

 

Input

One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)

then m lines ,each line contains two integers a and b ,stands for a's reward should be more than b's.

 

Output

For every case ,print the least money dandelion 's uncle needs to distribute .If it's impossible to fulfill all the works' demands ,print -1.

 

Sample Input

2 1
1 2
2 2
1 2
2 1

 

Sample Output

1777
-1

 

Author

dandelion

 

Source

曾是惊鸿照影来

思路:给出一些需求,某个人收到的钱要比另一个人多。求支付的最少钱数。

若需求成环,即A比B多,B比C多,C比A多,此类情况无法满足。

先进行一次拓扑排序,排序后若仍然有剩余,则说明有环,输出-1

若无环,则拓扑排序的最外层记作0,向内每层加一,(若某节点有两条支路,取更长的)

累计最大的数量,加总人数*888即可。

#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<algorithm>
#include<queue>
#include<string.h>
#include<math.h>
#include<vector>

using namespace std;

long long ans, n, sum, m;

struct node{
int in;
vector<int>out;
int dat = 0;
}data[10005];

queue<int>que;

int main()
{
while (cin >> n >> m)
{
ans = 0;
sum = 0;
for (size_t i = 0; i <= n; i++)
{
data[i].in = 0;
data[i].out.clear();
data[i].dat = 0;
}

for (size_t i = 0; i < m; i++)
{
int be, ed;
cin >> ed >> be;
data[be].out.push_back(ed);
data[ed].in++;
}

for (size_t i = 1; i <= n; i++)
{
if (data[i].in == 0)
{
que.push(i);
sum++;
}
}
while (!que.empty())
{
int list = data[que.front()].out.size();
for (size_t i = 0; i < list; i++)
{
data[data[que.front()].out[i]].in--;
if (data[data[que.front()].out[i]].in == 0)
{
sum++;
que.push(data[que.front()].out[i]);
data[data[que.front()].out[i]].dat = data[que.front()].dat + 1;
ans += data[data[que.front()].out[i]].dat;
}
}
que.pop();
}
if (sum < n)
{
cout << "-1\n";
}
else
{
cout << ans + n * 888 << "\n";
}
}
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息