您的位置:首页 > 其它

#HDU 2680 Choose the best route 【SPFA最短路】

2016-03-02 11:47 239 查看

题目:


Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 11846    Accepted Submission(s): 3846


Problem Description

One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take.
You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.

 

Input

There are several test cases. 

Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands
for the bus station that near Kiki’s friend’s home.

Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .

Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

 

Output

The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.

 

Sample Input

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

 

Sample Output

1
-1

 

Author

dandelion

 

Source

2009浙江大学计算机研考复试(机试部分)——全真模拟

思路: 经典的最短路问题,给出几条可行路径,求单源最短路径

算法较简单,依次以最短路径更新其周围的点,若某点被更新则加入队列,直到队列为空为止。

#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<algorithm>
#include<string.h>
#include<queue>

using namespace std;
#define MAX 1e9;

queue<int>que;
int city, road;
int vis[1005];

struct point{
int dis = 1e9;
int conect[1005][2];
int i = 0;
}node[1005];

int be, ed;

int main()
{

while (cin >> city >> road >> ed)
{
for (size_t i = 0; i <= city; i++)
{
node[i].dis = 1e9;
node[i].i = 0;
}
while (road--)
{
long a, b, c;
scanf("%d%d%d", &a, &b, &c);
node[a].conect[node[a].i][0] = b;
node[a].conect[node[a].i][1] = c;
node[a].i++;
}
int benum;
cin >> benum;
while (benum--)
{
memset(vis, 0, sizeof(vis));
scanf("%d", &be);
node[be].dis = 0;
que.push(be);
}
while (!que.empty())
{
be = que.front();
for (size_t i = 0; i < node[be].i; i++)
{
if (node[node[be].conect[i][0]].dis > node[be].dis + node[be].conect[i][1])
{
node[node[be].conect[i][0]].dis = node[be].dis + node[be].conect[i][1];
que.push(node[be].conect[i][0]);
}
}
que.pop();
}
if (node[ed].dis == 1e9)
{
cout << "-1\n";
}
else
{
cout << node[ed].dis << "\n";
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息