您的位置:首页 > 大数据 > 人工智能

1106 Lowest Price in Supply Chain

2016-02-28 10:12 357 查看
A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)– everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one’s supplier in a price P and sell or distribute them in a price that is r% higher than P. Only the retailers will face the customers. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the lowest price a customer can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence their ID’s are numbered from 0 to N-1, and the root supplier’s ID is 0); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then N lines follow, each describes a distributor or retailer in the following format:

Ki ID[1] ID[2] … ID[Ki]

where in the i-th line, Ki is the total number of distributors or retailers who receive products from supplier i, and is then followed by the ID’s of these distributors or retailers. Kj being 0 means that the j-th member is a retailer. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the lowest price we can expect from some retailers, accurate up to 4 decimal places, and the number of retailers that sell at the lowest price. There must be one space between the two numbers. It is guaranteed that the all the prices will not exceed 1010.

Sample Input:

10 1.80 1.00

3 2 3 5

1 9

1 4

1 7

0

2 6 1

1 8

0

0

0

Sample Output:

1.8362 2

解题思路:简单的广搜,当搜索到某一层有零售商的时候就停止搜索,但是要记录那一层所有零售商的数量。

要测试root直接为零售商的结果,一开始没有想到,导致测试点1一直运行超时,因为死循环了

input:

1 1.80 1.00

0

output:

1.8000 1

#include<iostream>
#include<stdio.h>
#include<vector>
#include<math.h>
using namespace std;
int main(){
int n;
double price;
double rate;
for (; scanf("%d%lf%lf", &n, &price, &rate) != EOF;){
vector<int>* arr = new vector<int>
;
int *arr_check = new int
;
for (int i = 0; i < n; i++){
int size;
scanf("%d", &size);
arr_check[i] = size;
arr[i] = vector<int>(size);
for (int j = 0; j < size;j++){
//int temp;
//scanf("%d", &temp);
//arr[i].push_back(temp);
scanf("%d", &arr[i][j]);
}
}
int level = 0;
int flag = 0;
int count = 0;
vector<int>vec;
vec.push_back(0);
//考虑root直接为零售商的情况
if (arr[0].size() == 0){
flag = 1;
count++;
}
while (!flag){
vector<int>temp;
for (int i = 0; i < vec.size(); i++){
for (int j = 0; j < arr[vec[i]].size(); j++){
if (arr_check[arr[vec[i]][j]] == 0){
flag = 1;
count++;
}
if (arr_check[arr[vec[i]][j]] != 0 && !flag)
temp.push_back(arr[vec[i]][j]);
}
}
level++;
vec = vector<int>(temp);
}
printf("%.4lf %d\n",price*pow(rate/100.0+1,level*1.0),count);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: