您的位置:首页 > 大数据 > 人工智能

Hanoi Tower Troubles Again! (找规律)

2016-02-27 19:33 1431 查看
Description

People stopped moving discs from peg to peg after they know the number of steps needed to complete the entire task. But on the other hand, they didn't not stopped thinking about similar puzzles with the Hanoi Tower. Mr.S invented
a little game on it. The game consists of N pegs and a LOT of balls. The balls are numbered 1,2,3... The balls look ordinary, but they are actually magic. If the sum of the numbers on two balls is NOT a square number, they will push each other with a great
force when they're too closed, so they can NEVER be put together touching each other.



The player should place one ball on the top of a peg at a time. He should first try ball 1, then ball 2, then ball 3... If he fails to do so, the game ends. Help the player to place as many balls as possible. You may take a look at the picture above, since
it shows us a best result for 4 pegs.

Input

The first line of the input contains a single integer T, indicating the number of test cases. (1<=T<=50) Each test case contains a single integer N(1<=N<=50), indicating the number of pegs available.

Output

For each test case in the input print a line containing an integer indicating the maximal number of balls that can be placed. Print -1 if an infinite number of balls can be placed.

Sample Input

2
4
25


Sample Output

11
337


#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<set>
#include<vector>
#include<map>
#include<cmath>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int N = 10000;
int f[111];
int main()
{
f[1]=1;f[2]=3;
int i,j,n,t;
int temp=2;
for(i=3;i<=50;i++) {
if(i%2) temp+=2;
f[i]=f[i-1]+temp;
}
cin>>t;
while(t--) {
cin>>n;
cout<<f
<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: