您的位置:首页 > 大数据 > 人工智能

hdu 1789 Doing Homework Again!

2016-02-25 20:38 615 查看


Problem Description

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final
test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.

Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced
scores.

Output

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input

3

3

3 3 3

10 5 1

3

1 3 1

6 2 3

7

1 4 6 4 2 4 3

3 2 1 7 6 5 4

Sample Output

0

3


5

这是在做一套dp训练题的时候做的,都怪这个,害我一开始就往dp方面想,一直没想出来。后来上网查了一下,基本上是贪心,看不到dp。

贪心思想,先按分数排序,然后,按分数从大到安排,时间上是从截止时间往前考虑。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
struct node
{
int day,sorce;
}a[1005];
bool mark[1005];
bool cmp(node a,node b)
{
return a.sorce>b.sorce;
}
int main()
{
int t,n,i,j,flag,sum;
scanf("%d",&t);
while(t--)
{
sum=0;
scanf("%d",&n);
for(i=1;i<=n;i++)
scanf("%d",&a[i].day);
for(i=1;i<=n;i++)
scanf("%d",&a[i].sorce);
sort(a+1,a+n+1,cmp);
memset(mark,0,sizeof(mark));
for(i=1;i<=n;i++)
{
flag=0;
for(j=a[i].day;j>0;j--)
{
if(mark[j]==0)
{
mark[j]=1;
flag=1;
break;
}
}
if(flag==0)
sum+=a[i].sorce;
}
printf("%d\n",sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: