您的位置:首页 > 大数据 > 人工智能

HDU 4300 Clairewd’s message

2016-02-18 23:25 489 查看

Clairewd’s message

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4666    Accepted Submission(s): 1777

[align=left]Problem Description[/align]
Clairewd is a member of FBI. After several years concealing in BUPT, she intercepted some important messages and she was preparing for sending it to ykwd. They had agreed that each letter of these messages would be transfered to another one according to a conversion table.

Unfortunately, GFW(someone's name, not what you just think about) has detected their action. He also got their conversion table by some unknown methods before. Clairewd was so clever and vigilant that when she realized that somebody was monitoring their action, she just stopped transmitting messages.

But GFW knows that Clairewd would always firstly send the ciphertext and then plaintext(Note that they won't overlap each other). But he doesn't know how to separate the text because he has no idea about the whole message. However, he thinks that recovering the shortest possible text is not a hard task for you.

Now GFW will give you the intercepted text and the conversion table. You should help him work out this problem.

Input

The first line contains only one integer T, which is the number of test cases.

Each test case contains two lines. The first line of each test case is the conversion table S. S is the ith latin letter's cryptographic letter. The second line is the intercepted text which has n letters that you should recover. It is possible that the text is complete.

[i]Hint

Range of test data:

T<= 100 ;

n<= 100000;

[align=left]Output[/align]
For each test case, output one line contains the shorest possible complete text.

[align=left]Sample Input[/align]
[align=left][/align]

2
abcdefghijklmnopqrstuvwxyz
abcdab
qwertyuiopasdfghjklzxcvbnm
qwertabcde

[align=left]Sample Output[/align]
[align=left][/align]

abcdabcd
qwertabcde

[align=left][/align]
题意是每组数据给定两个字符串,第一个是26个字母的字符串,代表着密文的转化规则,即密文的str[i]对应的是i + 'a',换句话说,比方说第二组数据,则密文q对应明文a,w对应b,以此类推。
第二个字符串是由一个密文串全部和明文串的一部分或全部组合而来的,比如第一组数据就是由密文串abcd和明文ab组成,而第二组数据是由密文qwert和明文abcde组成。
最后输出的是完整的密文+完整的明文

这个题我采取的方法是将给定的第二个字符串按照转化规则全部进行转化,然后以此为模板串x,以原串为主串y,通过扩展KMP算法,计算y[i...n-1]与x[0...n-1]的最长公共前缀(两者长队n必定相同)当满足i+extend[i]大于等于n并且满足i大于extend[i],这么做的原因是必须保证密文串长度大于等于明文串。

找到这个i以后,循环两遍输出结果即可
代码如下:

/*************************************************************************
> File Name: Clairewds_message.cpp
> Author: Zhanghaoran
> Mail: chilumanxi@xiyoulinux.org
> Created Time: 2016年02月18日 星期四 21时10分47秒
************************************************************************/

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cstdlib>
#include <string>
using namespace std;

int ss[26];
string str;
string temp;
char srt[100010];
int T;

int nexti[100010];
int N;

void pre_EKMP(){
nexti[0] = N;
int j = 0;
while(j + 1 < N && srt[j] == srt[j + 1])
j ++;
nexti[1] = j;
int k = 1;
for(int i = 2; i < N; i ++){
int p = nexti[k] + k - 1;
int L = nexti[i - k];
if(i + L < p + 1)
nexti[i] = L;
else{
j = max(0, p - i + 1);
while(i + j < N && srt[i + j] == srt[j])
j ++;
nexti[i] = j;
k = i;
}
}
}

int extend[100010];

void EKMP(){
pre_EKMP();
int j = 0;
while(j < N && j < N && str[j] == srt[j])
j ++;
extend[0] = j;
int k = 0;
for(int i = 1; i < N ; i ++){
int p = extend[k] + k - 1;
int L = nexti[i - k];
if(i + L < p + 1)
extend[i] = L;
else{
j = max(0, p - i + 1);
while(i + j < N && j < N && str[i + j] == srt[j])
j ++;
extend[i] = j;
k = i;
}
}
}
int main(void){
cin >> T;
while(T --){
cin >> temp;
for(int i = 0; i < temp.size(); i ++){
ss[temp[i] - 'a'] = temp[i] - 'a' - i;
}
cin >> str;
memset(srt, 0, sizeof(srt));
for(int i = 0; i < str.size(); i ++){
srt[i] = str[i] - ss[str[i] - 'a'];
}
N = str.size();
EKMP();
int k;
for(k= 0; k< N; k++)
{
if(k + extend[k] >= N && k >= extend[k])
break;
}
for(int i = 0; i < k; i ++)
printf("%c",str[i]);
for(int i = 0; i < k; i ++)
printf("%c",srt[i]);
puts("");
}
}

 

查看原文:http://chilumanxi.org/2016/02/18/hdu-4300-clairewds-message/
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: