您的位置:首页 > 其它

HDU1213并查集

2016-02-01 16:42 337 查看


How Many Tables

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 20894 Accepted Submission(s): 10340



Problem Description

Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.

Input

The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines
follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.

Output

For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.

Sample Input

2
5 3
1 2
2 3
4 5

5 1
2 5


Sample Output

2
4


水题

给出代码:

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
#include<cmath>

using namespace std;

const int MAX_N = 1000 + 20;
int n, m, a, b, tally;
int par[MAX_N], degree[MAX_N];

void init(){
for(int i = 1; i <= n; i++){
degree[i] = 0;
par[i] = i;
}
}

int find(int x){
if(par[x] == x) return x;
return par[x] = find(par[x]);
}

bool same(int x, int y){
return find(x) == find(y);
}

void unite(int x, int y){
x = find(x);
y = find(y);
if(x == y) return ;
if(degree[y] > degree[x]){
par[x] = y;
}
else {
par[y] = x;
if(degree[x] == degree[y])degree[x]++;
}

}

void solve(){
scanf("%d%d", &n, &m);
tally = 0;
init();

for(int i = 1; i <= m; i++){
scanf("%d%d", &a, &b);
//printf("%d\n", !same(a, b));
//printf("%d %d\n", a, b);
        if(!same(a, b)){
tally++;
unite(a, b);
}
}
//printf("%d\n", tally);
printf("%d\n", n - tally);
}

int main(){
int t;
scanf("%d", &t);
while(t--)solve();
return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: