您的位置:首页 > 其它

HDU3371 并查集与最小生成树(判断有无生成树)

2016-02-02 21:53 381 查看


Connect the Cities

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 15073 Accepted Submission(s): 4037



Problem Description

In 2100, since the sea level rise, most of the cities disappear. Though some survived cities are still connected with others, but most of them become disconnected. The government wants to build some roads to connect all of these cities again, but they don’t
want to take too much money.

Input

The first line contains the number of test cases.

Each test case starts with three integers: n, m and k. n (3 <= n <=500) stands for the number of survived cities, m (0 <= m <= 25000) stands for the number of roads you can choose to connect the cities and k (0 <= k <= 100) stands for the number of still connected
cities.

To make it easy, the cities are signed from 1 to n.

Then follow m lines, each contains three integers p, q and c (0 <= c <= 1000), means it takes c to connect p and q.

Then follow k lines, each line starts with an integer t (2 <= t <= n) stands for the number of this connected cities. Then t integers follow stands for the id of these cities.

Output

For each case, output the least money you need to take, if it’s impossible, just output -1.

Sample Input

1
6 4 3
1 4 2
2 6 1
2 3 5
3 4 33
2 1 2
2 1 3
3 4 5 6


Sample Output

1


遇到的问题和思路:

最近真的是被自己蠢哭了。。。输入时候的输入顺序弄错了害我WA了无数次。

判断有没有全部连接在一起。要么就是看看边的个数和顶点个数的是不是满足 边 = 顶点 - 1的公式。或者我个人的想法就是看看第一个顶点(题目意思就是第一个顶点一定存在),和其他顶点有没有连成一片就好了。

给出AC代码(一定要用G++交,C++TLE了)



#include<cstdio>
#include<algorithm>
#include<cstring>

using namespace std;

struct edge{
int from, to1, cost;
};
int n, m, k, c;
long long res;
edge ed[30000];
int par[30000], rank1[30000], a[30000];

void init(){
for(int i = 0; i <= n; i++){
par[i] = i;
rank1[i] = 0;
}
}

int find(int x){
if(par[x] == x)return x;
return par[x] = find(par[x]);
}

bool same(int x, int y){
return find(x) == find(y);
}

void unite(int x, int y){
x = find(x);
y = find(y);
if(x == y)return ;
if(rank1[x] > rank1[y])par[y] = x;
else {
par[x] = y;
if(rank1[x] == rank1[y])rank1[x]++;
}
}

bool cmp(const edge &e1, const edge & e2){
return e1.cost < e2.cost;
}

void solve(){
res = 0;
sort(ed + 1, ed + m + 1, cmp);
for(int i = 1; i <= m; i++){
if(ed[i].from > n || ed[i].to1 > n || ed[i].from < 1 || ed[i].to1 < 1)continue;
if(!same(ed[i].from, ed[i].to1)){
unite(ed[i].from, ed[i].to1);
res += ed[i].cost;
}
}
for(int i = 2; i <= n; i++){
if(!same(1, i))res = -1;
}
printf("%I64d\n", res);
}

int main(){
int t;
scanf("%d", &t);
while(t--){
memset(ed, 0, sizeof(ed));
scanf("%d%d%d", &n, &m, &k);
for(int i = 1; i <= m; i++){
scanf("%d%d%d", &ed[i].from, &ed[i].to1, &ed[i].cost);
}
init();
for(int i = 1; i <= k; i++){
int f;
scanf("%d", &f);
for(int i = 1; i <= f; i++){
scanf("%d", &a[i]);
}
for(int i = 1; i < f; i++){
if(a[i] > n || a[i + 1] > n || a[i] < 1 || a[i + 1] < 1)continue;
if(!same(a[i], a[i + 1]))unite(a[i], a[i + 1]);
}
}
solve();
}
return 0;
}

</cstring></algorithm></cstdio>
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: