您的位置:首页 > 其它

hdoj1009FatMouse' Trade

2016-01-30 15:35 309 查看
[align=left]Problem Description[/align]
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.

The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of
cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

[align=left]Input[/align]
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case
is followed by two -1's. All integers are not greater than 1000.

[align=left]Output[/align]
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

[align=left]Sample Input[/align]

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1


[align=left]Sample Output[/align]

13.333
31.500


代码:
#include<algorithm>
#include<iostream>
#include<string.h>
using namespace std;
struct stu{
double j,f;
double sum;
}a[1100];
bool cmp(stu a,stu b)
{
return a.sum>b.sum;
}
int main()
{
int n,m,i;
double p;
while(scanf("%d%d",&n,&m)!=EOF)
{
p=0;
if(n==-1&&m==-1)
break;
for(i=0;i<m;i++)
{
scanf("%lf%lf",&a[i].j,&a[i].f);
a[i].sum=a[i].j/a[i].f;
}
sort(a,a+m,cmp);
for(i=0;i<m;i++)
{
if(a[i].f<=n)
{
n=n-a[i].f;
p+=a[i].j;
}
else
{
p+=(n/a[i].f)*a[i].j;
break;
}
}
printf("%.3lf\n",p);
}
return 0;
}
思路:简单的贪心题,比较比值大小然后加起来就行了。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: