您的位置:首页 > 其它

1030

2016-01-05 23:14 330 查看


Delta-wave

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7091    Accepted Submission(s): 2739


Problem Description

A triangle field is numbered with successive integers in the way shown on the picture below. 



The traveller needs to go from the cell with number M to the cell with number N. The traveller is able to enter the cell through cell edges only, he can not travel from cell to cell through vertices. The number of edges the traveller passes makes the length
of the traveller's route. 

Write the program to determine the length of the shortest route connecting cells with numbers N and M. 

 

Input

Input contains two integer numbers M and N in the range from 1 to 1000000000 separated with space(s).

 

Output

Output should contain the length of the shortest route.

 

Sample Input

6 12

 

Sample Output

3

    总之先建立个
4000
坐标系吧



    这样建系,可以看出一个点要到第二个点只用先沿着坐标系走,然后再走相距的层数就行了

    于是答案就是△x+△y+△row

     row=(int)sqrt(n-1);

     x=(n-row*row-1)/2;

     y=((row+1)*(row+1)-n)/2;

#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;

int n,m;
int x_1,x_2,y_1,y_2;

int main()
{
freopen("input.txt","r",stdin);
freopen("output.txt","w",stdout);
while(scanf("%d%d",&n,&m)==2)
{
int row_1=(int)sqrt(n-1);
x_1=(n-row_1*row_1-1)/2;
y_1=((row_1+1)*(row_1+1)-n)/2;

int row_2=(int)sqrt(m-1);
x_2=(m-row_2*row_2-1)/2;
y_2=((row_2+1)*(row_2+1)-m)/2;

printf("%d\n",abs(x_1-x_2)+abs(y_1-y_2)+abs(row_1-row_2));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: