您的位置:首页 > 其它

poj 1018(dp)

2016-01-01 18:54 274 查看
Communication System

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 25653Accepted: 9147
Description

We have received an order from Pizoor Communications Inc. for a special communication system. The system consists of several devices. For each device, we are free to choose from several manufacturers. Same devices from two manufacturers differ in their maximum bandwidths and prices.
By overall bandwidth (B) we mean the minimum of the bandwidths of
the chosen devices in the communication system and the total price (P)
is the sum of the prices of all chosen devices. Our goal is to choose a
manufacturer for each device to maximize B/P.

Input

The
first line of the input file contains a single integer t (1 ≤ t ≤ 10),
the number of test cases, followed by the input data for each test case.
Each test case starts with a line containing a single integer n (1 ≤ n ≤
100), the number of devices in the communication system, followed by n
lines in the following format: the i-th line (1 ≤ i ≤ n) starts with mi
(1 ≤ mi ≤ 100), the number of manufacturers for the i-th device,
followed by mi pairs of positive integers in the same line, each
indicating the bandwidth and the price of the device respectively,
corresponding to a manufacturer.
Output

Your
program should produce a single line for each test case containing a
single number which is the maximum possible B/P for the test case. Round
the numbers in the output to 3 digits after decimal point.

Sample Input

1 3
3 100 25 150 35 80 25
2 120 80 155 40
2 100 100 120 110

Sample Output

0.649

思路:定义dp[i][j]为前i个设备的容量为j的最小费用;
    状态转移方程为:dp[i][j]=min(dp[i][j],dp[i-1][j]+p);
    边界:dp[1][j]=p;  
    

  


#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cstdlib>
#include<iomanip>
#include<cmath>
#include<vector>
#include<queue>
#include<stack>
using namespace std;
#define PI 3.141592653589792128462643383279502
const int inf=0x3f3f3f3f;
int t,n,j,ss,m[120][1200];
int main(){
//#ifdef CDZSC_June
//freopen("in.txt","r",stdin);
//#endif
//std::ios::sync_with_stdio(false);
scanf("%d",&t);
while(t--){
scanf("%d",&n);
memset(m,0x3f,sizeof(m));
for(int i=1;i<=n;i++){
int num;
scanf("%d",&num);
for(j=1;j<=num;j++){
int b,p;
scanf("%d%d",&b,&p);
if(i==1){m[1][b]=min(m[1][b],p);}
else {
for(int k=0;k<1200;k++){
if(m[i-1][k]!=inf){
if(k<=b)
m[i][k]=min(m[i][k],m[i-1][k]+p);
else
m[i][b]=min(m[i][b],m[i-1][k]+p);
}
}
}
}
}
double ans=0;
for(int i=0;i<1200;i++){
if(m
[i]!=inf){
double k=(double)i/m
[i];
if(k>ans) ans=k;
}
}
printf("%.3lf\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: