您的位置:首页 > 其它

UVA 111(LCS问题)

2016-01-01 23:35 323 查看
History Grading

Background

Many problems in Computer Science involve maximizing some measure according to constraints.Consider a history exam in which students are asked to put several historical events into chronological order. Students who order all the events correctly will receive full credit, but how should partial credit be awarded to students who incorrectly rank one or more of the historical events?Some possibilities for partial credit include:1 point for each event whose rank matches its correct rank1 point for each event in the longest (not necessarily contiguous) sequence of events which are in the correct order relative to each other.For example, if four events are correctly ordered 1 2 3 4 then the order 1 3 2 4 would receive a score of 2 using the first method (events 1 and 4 are correctly ranked) and a score of 3 using the second method (event sequences 1 2 4 and 1 3 4 are both in the correct order relative to each other).In this problem you are asked to write a program to score such questions using the second method.

The Problem

Given the correct chronological order of n events

as

where

denotes the ranking of eventi in the correct chronological order and a sequence of student responses

where

denotes the chronological rank given by the student to event i; determine the length of the longest (not necessarily contiguous) sequence of events in the student responses that are in the correct chronological order relative to each other.

The Input

The first line of the input will consist of one integer n indicating the number of events with

. The second line will contain n integers, indicating the correct chronological order of n events. The remaining lines will each consist of nintegers with each line representing a student's chronological ordering of the n events. All lines will contain n numbers in the range

, with each number appearing exactly once per line, and with each number separated from other numbers on the same line by one or more spaces.

The Output

For each student ranking of events your program should print the score for that ranking. There should be one line of output for each student ranking.

Sample Input 1

4
4 2 3 1
1 3 2 4
3 2 1 4
2 3 4 1

Sample Output 1

1
2
3

Sample Input 2

10
3 1 2 4 9 5 10 6 8 7
1 2 3 4 5 6 7 8 9 10
4 7 2 3 10 6 9 1 5 8
3 1 2 4 9 5 10 6 8 7
2 10 1 3 8 4 9 5 7 6

Sample Output 2

6
5
10
9

思路:化简成LCS问题;
   正确排序s【】与学生排序p【】的LCS问题:
    定义状态转移方程:f【i】【j】为p【】的前i个元素与s【】的前j个元素的LCS长度;
    for(i=1;i<=n;i++)
    for(j=1;j<=n;j++){
      f[i][j]=max(f[i][j-1],f[i-1][j]);
      if(s[j]==p[i])
      f[i][j]=max(f[i][j],f[i-1][j-1]+1);
    }
      边界为f[0][0]=0;
注意:输入时s[]与p[]的后缀是事件时间;内容是位置;如果调换了会WA;
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cstdlib>
#include<iomanip>
#include<cmath>
#include<vector>
#include<queue>
#include<stack>
using namespace std;
#define PI 3.141592653589792128462643383279502
int p[30],s[30],n;
int f[30][30];
int main(){
//#ifdef CDZSC_June
freopen("in.txt","r",stdin);
//#endif
//std::ios::sync_with_stdio(false);
cin>>n;
int x;
memset(p,0,sizeof(p));
memset(s,0,sizeof(s));
for(int i=1;i<=n;i++){
cin>>x;s[x]=i;
}
while(!cin.eof()){
for(int i=1;i<=n;i++){
cin>>x;p[x]=i;
}
memset(f,0,sizeof(f));
for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++){
f[i][j]=max(f[i-1][j],f[i][j-1]);
if(s[i]==p[j])
f[i][j]=max(f[i][j],f[i-1][j-1]+1);
}
cout<<f

<<endl;
}
return 0;
}

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: