您的位置:首页 > 其它

【hdu】1241-Oil Deposits(DFS)(水)

2015-12-24 18:36 351 查看
Oil Deposits
Crawling in process...
Crawling failed
Time Limit:1000MS
Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Submit

Status

Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots.
It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large
and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.



Input

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100
and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.



Output

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.



Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0




Sample Output

0
1
2
2


这道题难度不大,但是因为读题错误而WA了3次,再次贴上,警示自己。

代码如下:

#include <stdio.h>
int x,y,W,H,num;
char map[111][111];
int ans[5000];
int move_x[8]={0,0,-1,1,1,1,-1,-1};
int move_y[8]={1,-1,0,0,1,-1,-1,1};		//移动
void dfs(int x,int y)
{
	if (x<0||x>=H||y<0||y>=W)
		return;
	if (map[x][y]=='*')
		return;
	map[x][y]='*';
	for (int i=0;i<8;i++)
		dfs(x+move_x[i],y+move_y[i]);
}
int main()
{
	while (~scanf ("%d %d",&H,&W) && H)
	{
		for (int i=0;i<H;i++)
		{
			scanf ("%s",map[i]);
		}
		num=0;
		for (int i=0;i<H;i++)
		{
			for (int j=0;j<W;j++)
			{
				if (map[i][j]=='@')
				{
					dfs(i,j);
					num++;
				}
			}
		}
		printf ("%d\n",num);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: