您的位置:首页 > 其它

hdu--1011

2015-12-24 18:34 489 查看


Starship Troopers

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 15065 Accepted Submission(s): 4046



Problem Description

You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some
of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is
one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight
all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the
problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.

Input

The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines
give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers,
which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.

Output

For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.

Sample Input

5 10
50 10
40 10
40 20
65 30
70 30
1 2
1 3
2 4
2 5
1 1
20 7
-1 -1


Sample Output

50
7


解体思路:第一道树状dp,在求解转移方程时,这里和背包类似..有人说树状DP,与其他不同的也就是添加进了树的元素,每个元素的选择有了限制,就变成了父元素与其子元素的最优解。感觉有道理,

代码如下:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int bug[110];
int pos[110];
struct stu{
int f,t,ne;//w表示虫子数量,v表示可能概率
};
stu edge[10000+100];
int head[110];
int vist[110];
int num,n,m;
int dp[110][110];
void inin(){
num=0;
memset(head,-1,sizeof(head));
}
void add(int a,int b){
stu E={a,b,head[a]};
edge[num]=E;
head[a]=num++;
}
//void dfs(int id,int cost,int val){
//	if(cost>m)return ;
//    if(val>ans)ans=val;
//	for(int i=head[id];i!=-1;i=edge[i].ne){
//		int v=edge[i].t;
//		if(!vist[v]){
//			vist[v]=1;
//			int fx=(bug[v]+19)/20;
//			dfs(v,cost+fx,val+pos[v]);
//			//vist[v]=0;
//		}
//	}
//}
void dfs(int root){
vist[root]=1;
int temp=(bug[root]+19)/20;
for(int i=temp;i<=m;i++){
dp[root][i]=pos[root];//temp以上的都可以有pos值
}
for(int i=head[root];i!=-1;i=edge[i].ne){
int son=edge[i].t;
if(!vist[son]){
dfs(son);
for(int j=m;j>=temp;j--){
for(int k=1;k<=j-temp;k++)
dp[root][j]=max(dp[root][j],dp[root][j-k]+dp[son][k]);//每一个子树使其父节点最优
}

}

}
}
int main(){
int a,b;
while(scanf("%d%d",&n,&m)){
if(n==-1&&m==-1)break;
inin();
for(int i=1;i<=n;i++){
scanf("%d%d",&bug[i],&pos[i]);
}
for(int i=1;i<=n-1;i++){
scanf("%d%d",&a,&b);
add(a,b);
add(b,a);
}
if(m==0){
printf("0\n");
continue;
}
memset(dp,0,sizeof(dp));
memset(vist,0,sizeof(vist));
dfs(1);
printf("%d\n",dp[1][m]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: