您的位置:首页 > 其它

hdu--2674

2015-12-01 18:47 267 查看
Description

WhereIsHeroFrom: Zty, what are you doing ?

Zty: I want to calculate N!......

WhereIsHeroFrom: So easy! How big N is ?

Zty: 1 <=N <=1000000000000000000000000000000000000000000000…

WhereIsHeroFrom: Oh! You must be crazy! Are you Fa Shao?

Zty: No. I haven's finished my saying. I just said I want to calculate N! mod 2009

Hint : 0! = 1, N! = N*(N-1)!

Input

Each line will contain one integer N(0 <= N<=10^9). Process to end of file.

Output

For each case, output N! mod 2009

Sample Input

4
5


Sample Output

24
120


解体思路:(1*2*3*4..............*n)%2009=((.....((1%2009)*2)%2009.....)*n)%2009;又2009=7*7*41,所以比41大的数结果都为0;问题缩小到了41。接下来处理问题就变得简单多了。

代码如下:
#include<stdio.h>
#include<string.h>
int main(){
long long n,m;
while(scanf("%lld",&n)!=EOF){
if(n>=41){
printf("0\n");
continue;
}
else if(n==0){
printf("1\n");
}
else {
m=1;
for(int i=1;i<=n;i++){
m=(m*i)%2009;
}
printf("%d\n",m%2009);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: