您的位置:首页 > 其它

Light oj--1275(二次函数)

2015-12-03 21:17 316 查看
Description

A group of N Internet Service Provider companies (ISPs) use a private communication channel that has a maximum capacity of C traffic units per second. Each company transfers T traffic units per second through
the channel and gets a profit that is directly proportional to the factor T(C - T*N). The problem is to compute the smallest value of T that maximizes the total profit the N ISPs can get from using the channel.
Notice that N, C, T, and the optimal T are integer numbers.

Input

Input starts with an integer T (≤ 20), denoting the number of test cases.

Each case starts with a line containing two integers N and C (0 ≤ N, C ≤ 109).

Output

For each case, print the case number and the minimum possible value of T that maximizes the total profit. The result should be an integer.

Sample Input

6

1 0

0 1

4 3

2 8

3 27

25 1000000000

Sample Output

Case 1: 0

Case 2: 0

Case 3: 0

Case 4: 2

Case 5: 4

Case 6: 20000000

解题思路: 题目表示看了很久,后来才明白题意,就是求保证T(C - T*N)达到最大值.时,T取最小值.注意T是整数,问题就转换成二次函数中点到顶点的距离了。但当c==0||n==0时不是二次函数,输出0就行了。

代码如下:

#include<stdio.h>
#include<string.h>
int main(){
int t,n,c,cas,s;
double m;
cas=1;
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&c);
printf("Case %d: ", cas++);
if(n==0||c==0){
printf("0\n");
continue;
}
m=c*1.0/(2*n);
s=(int)m;
if(s+1-m<m-s)
printf("%d\n",s+1);
else
printf("%d\n",s);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: