您的位置:首页 > 其它

hdu--1034

2015-12-07 10:04 155 查看


Candy Sharing Game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4444 Accepted Submission(s): 2714



Problem Description

A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right.
Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.

Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.

Input

The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is
on a line by itself.

Output

For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.

Sample Input

6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0


Sample Output

15 14
17 22
4 8

Hint
The game ends in a finite number of steps because:
1. The maximum candy count can never increase.
2. The minimum candy count can never decrease.
3. No one with more than the minimum amount will ever decrease to the minimum.
4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.

解题思路:这题就是简单的将步骤模拟一遍.没有什么难度.

代码如下:
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int c[1000100];
int v[1000100];
int main(){
int n;
while(scanf("%d",&n)){
if(n==0)break;
for(int i=0;i<n;i++){
scanf("%d",&c[i]);
}
int sum=0;
while(1){
for(int i=0;i<n;i++){
v[i]=c[i];
}
sort(v,v+n);
if(v[0]==v[n-1])break;
for(int i=0;i<n;i++){
v[i]=c[i]/2;
c[i]-=c[i]/2;
}
for(int i=0;i+1<n;i++){
c[i+1]+=v[i];
if(c[i+1]%2)
c[i+1]++;
}
c[0]+=v[n-1];
if(c[0]%2)
c[0]++;
sum++;
}
printf("%d %d\n",sum,v[0]);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: