您的位置:首页 > 其它

1070. Mooncake

2015-11-29 19:48 447 查看


1070. Mooncake (25)

时间限制

100 ms

内存限制

65536 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

Mooncake is a Chinese bakery product traditionally eaten during the Mid-Autumn Festival. Many types of fillings and crusts can be found in traditional mooncakes according to the region's culture. Now given the inventory amounts and the prices of all kinds of
the mooncakes, together with the maximum total demand of the market, you are supposed to tell the maximum profit that can be made.

Note: partial inventory storage can be taken. The sample shows the following situation: given three kinds of mooncakes with inventory amounts being 180, 150, and 100 thousand tons, and the prices being 7.5, 7.2, and 4.5 billion yuans. If the market demand can
be at most 200 thousand tons, the best we can do is to sell 150 thousand tons of the second kind of mooncake, and 50 thousand tons of the third kind. Hence the total profit is 7.2 + 4.5/2 = 9.45 (billion yuans).

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (<=1000), the number of different kinds of mooncakes, and D (<=500 thousand tons), the maximum total demand of the market. Then the second line gives the positive
inventory amounts (in thousand tons), and the third line gives the positive prices (in billion yuans) of N kinds of mooncakes. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the maximum profit (in billion yuans) in one line, accurate up to 2 decimal places.
Sample Input:
3 200
180 150 100
7.5 7.2 4.5

Sample Output:
9.45

考查:排序/贪心

CASE 4:段错误,在于d可能很大,用不完,从而导致数组越界。

#include<stdio.h>
#include<iostream>
#include<algorithm>
using namespace std;

struct Mooncake
{
float price;
float amounts;
float ratio;
}buf[1002];

bool cmp(Mooncake A, Mooncake B)
{
return A.ratio > B.ratio;
}

int main()
{
freopen("F://temp/input.txt", "r", stdin);
int n, d;
double profit = 0;
scanf("%d%d", &n, &d);

for(int i = 0; i < n; i ++)
scanf("%f", &buf[i].amounts);
for(int i = 0; i < n; i++)
{
scanf("%f", &buf[i].price);
buf[i].ratio = buf[i].price / buf[i].amounts;
}

sort(buf, buf+n, cmp);

for(int i = 0; d > 0 && i < n; i ++)
{
if(d < buf[i].amounts)
{
profit = profit + d*1.0/buf[i].amounts*buf[i].price;
break;
}
else
{
profit += buf[i].price;
d -= buf[i].amounts;
}
}

printf("%.2f\n", profit);
return 0;
}


[/code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: