您的位置:首页 > 理论基础 > 数据结构算法

数据结构实验之二叉树五:层序遍历

2015-11-08 11:44 309 查看

数据结构实验之二叉树五:层序遍历

Time Limit: 1000MS Memory limit: 65536K

题目描述

已知一个按先序输入的字符序列,如abd,,eg,,,cf,,,(其中,表示空结点)。请建立二叉树并求二叉树的层次遍历序列。

输入

输入数据有多行,第一行是一个整数t (t<1000),代表有t行测试数据。每行是一个长度小于50个字符的字符串。

输出

输出二叉树的层次遍历序列。

示例输入

2
abd,,eg,,,cf,,,
xnl,,i,,u,,


示例输出

abcdefg
xnuli


提示

来源

xam

示例程序

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
char a[100];
int l1;
struct node
{
int data;
struct node *lchild,*rchild;
};
struct node *creat()
{
struct node  *root;
char c;
c=a[l1++];
if(c==',')
return NULL;
else
{
root=(struct node *)malloc(sizeof(struct node));
root->data=c;
root->lchild=creat();
root->rchild=creat();

}
return root;
}
void cengci(struct node *root)
{
int out=0,in=0;
struct node *q[100];
q[in++]=root;
while(in>out)
{
if(q[out])
{
printf("%c",q[out]->data);
q[in++]=q[out]->lchild;
q[in++]=q[out]->rchild;
}
out++;
}
}
int main()
{
int i,j,n,m,k,t;
struct node *root;
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<n;i++)
{
scanf("%s",a);
l1=0;
root=(struct node *)malloc(sizeof(struct node));
root=creat();
cengci(root);
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: