您的位置:首页 > 产品设计 > UI/UE

poj 1458 Common Subsequence (最长公共子序列)

2015-10-28 20:23 204 查看
http://poj.org/problem?id=1458

Common Subsequence

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1,
i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find
the length of the maximum-length common subsequence of X and Y.
Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.
Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
Sample Input
abcfbc         abfcab
programming    contest
abcd           mnp

Sample Output
4
2
0


这是一个裸的最长公共子序列,题目意思是给出两个字符串,求他们的最长公共子序列
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <limits>
#include <queue>
#include <stack>
#include <vector>
#include <map>

using namespace std;

#define N 1400
#define INF 0x3f3f3f3f
#define PI acos (-1.0)
#define EPS 1e-8
#define met(a, b) memset (a, b, sizeof (a))

typedef long long LL;

int dp

;

int same (int a, int b)
{
if (a == b) return 1;
return 0;
}

int main ()
{
char s1
, s2
;
while (~scanf ("%s%s", s1, s2))
{
met (dp, 0);
int len1 = strlen (s1), len2 = strlen (s2);

for (int i=1; i<=len1; i++)
for (int j=1; j<=len2; j++)
dp[i][j] = max (dp[i-1][j-1] + same (s1[i-1], s2[j-1]), max (dp[i-1][j], dp[i][j-1]));
printf ("%d\n", dp[len1][len2]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: