您的位置:首页 > 产品设计 > UI/UE

uestc 1222 Sudoku

2015-10-28 18:29 363 查看

Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)


Submit 
Status

Yi Sima was one of the best counselors of Cao Cao. He likes to play a funny game himself. It looks like the modern Sudoku, but smaller.
Actually, Yi Sima was playing it different. First of all, he tried to generate a 4×4 board
with every row contains 1 to 4,
every column contains 1 to 4.
Also he made sure that if we cut the board into four 2×2 pieces,
every piece contains 1 to 4.
Then, he removed several numbers from the board and gave it to another guy to recover it. As other counselors are not as smart as Yi Sima, Yi Sima always made sure that the board only has one way to recover.
Actually, you are seeing this because you've passed through to the Three-Kingdom Age. You can recover the board to make Yi Sima happy and be promoted. Go and do it!!!


Input

The first line of the input gives the number of test cases, T(1≤T≤100). T test
cases follow. Each test case starts with an empty line followed by 4 lines.
Each line consist of 4characters.
Each character represents the number in the corresponding cell (one of 
1
2
3
4
). 
*
 represents
that number was removed by Yi Sima.
It's guaranteed that there will be exactly one way to recover the board.


Output

For each test case, output one line containing 
Case
#x:
, where x is
the test case number (starting from 1).
Then output 4 lines
with 4 characters
each. indicate the recovered board.


Sample input and output

Sample InputSample Output
3

****
2341
4123
3214

*243
*312
*421
*134

*41*
**3*
2*41
4*2*

Case #1:
1432
2341
4123
3214
Case #2:
1243
4312
3421
2134
Case #3:
3412
1234
2341
4123


Source

The 2015 China Collegiate Programming Contest

这题可以用dfs,因为忘记回溯,一直出错。。

#include<iostream>
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<queue>
#include<stack>
#include<string>
#include<algorithm>
using namespace std;
typedef long long ll;
#define inf 0x7fffffff
int num[10][10];
char s[10][10];
int gra[10][10];
int flag;
void init()
{
num[1][1]=1;
num[1][2]=1;
num[2][1]=1;
num[2][2]=1;

num[1][3]=2;
num[1][4]=2;
num[2][3]=2;
num[2][4]=2;

num[3][1]=3;
num[3][2]=3;
num[4][1]=3;
num[4][2]=3;

num[3][3]=4;
num[3][4]=4;
num[4][3]=4;
num[4][4]=4;
}

int check1(int x)
{
int i,j;
int tot[10];
for(i=1;i<=4;i++)tot[i]=0;
for(j=1;j<=4;j++){
tot[gra[x][j] ]++;
}
for(j=1;j<=4;j++){
if(tot[j]>=2)return 0;
}
return 1;
}

int check2(int y)
{
int i,j;
int tot[10];
for(i=1;i<=4;i++)tot[i]=0;
for(i=1;i<=4;i++){
tot[gra[i][y] ]++;
}
for(i=1;i<=4;i++){
if(tot[i]>=2)return 0;
}
return 1;
}

int check3(int num1)
{
int i,j;
int tot[10];
for(i=1;i<=4;i++)tot[i]=0;
for(i=1;i<=4;i++){
for(j=1;j<=4;j++){
if(num[i][j]==num1){
tot[gra[i][j] ]++;
}
}
}
for(i=1;i<=4;i++){
if(tot[i]>=2)return 0;
}
return 1;
}

void dfs(int x,int y)
{
int i,j,t1,t2,t3;
if(x==5){
flag=1;return;
}

if(gra[x][y]>0){
t1=check1(x);
t2=check2(y);
t3=check3(num[x][y]);
if((t1==0) || (t2==0) || (t3==0))return;
if(y==4){
dfs(x+1,1);
}
else dfs(x,y+1);
}
else if(gra[x][y]==0){
for(i=1;i<=4;i++){
gra[x][y]=i;
t1=check1(x);
t2=check2(y);
t3=check3(num[x][y] );
if((t1==0) || (t2==0) || (t3==0))continue;
if(y==4)dfs(x+1,1);
else dfs(x,y+1);
if(flag)return;
else continue;
}
gra[x][y]=0; //不要忘记回溯= =
return;
}

}

int main()
{
int n,m,i,j,T,k,cas=0;
init();
scanf("%d",&T);
while(T--)
{
for(i=1;i<=4;i++){
scanf("%s",s[i]+1);
for(j=1;j<=4;j++){
if(s[i][j]=='*')gra[i][j]=0;
else gra[i][j]=s[i][j]-'0';
}
}
flag=0;
dfs(1,1);
cas++;
printf("Case #%d:\n",cas);
for(i=1;i<=4;i++){
for(j=1;j<=4;j++){
printf("%d",gra[i][j]);
}
printf("\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: