您的位置:首页 > 其它

Uvalive—5462 Coconuts, Revisited

2015-10-26 17:07 288 查看
The short story titled Coconuts, by Ben Ames Williams, appeared in the Saturday Evening Post on October 9, 1926. The story tells about five men and a monkey who were shipwrecked on an island. They spent the first night gathering coconuts. During the night, one man woke up and decided to take his share of the coconuts. He divided them into five piles. One coconut was left over so he gave it to the monkey, then hid his share and went back to sleep.

Soon a second man woke up and did the same thing. After dividing the coconuts into five piles, one coconut was left over which he gave to the monkey. He then hid his share and went back to bed. The third, fourth, and fifth man followed exactly the same procedure. The next morning, after they all woke up, they divided the remaining coconuts into five equal shares. This time no coconuts were left over.

An obvious question is ``how many coconuts did they originally gather?" There are an infinite number of answers, but the lowest of these is 3,121. But that's not our problem here.

Suppose we turn the problem around. If we know the number of coconuts that were gathered, what is the maximum number of persons (and one monkey) that could have been shipwrecked if the same procedure could occur?

Input 

The input will consist of a sequence of integers, each representing the number of coconuts gathered by a group of persons (and a monkey) that were shipwrecked. The sequence will be followed by a negative number.

Output 

For each number of coconuts, determine the largest number of persons who could have participated in the procedure described above. Display the results similar to the manner shown below, in the Sample Output. There may be no solution for some of the input cases; if so, state that observation.

Sample Input 

25

30

3121

-1

Sample Output 

25 coconuts, 3 people and 1 monkey

30 coconuts, no solution

3121 coconuts, 5 people and 1 monkey

 
题目大意:一群水手(s人)和猴子流浪在一个孤岛上,为了生存,水手们采集了一些椰子,夜晚的时候第一个人醒来,把椰子分成s份,发现多了一个,就把多的这个给了猴子,取走其中一份,剩下s-1份,第二个人醒来也做了同样的事……一直到第s个人取完,剩下的椰子刚好能分成s份。问题是倒过来的,给出n个椰子,问最多有多少人分。

 
思路:刚开始想到用打表的方法把1-10人的所有椰子数打出来,查表即可,后来wa了几次,才明白这样打漏了情况,比如当有三个人时,椰子数可能25,也可能是一个大于25的数,后来想想,算了直接模拟吧!根据n个椰子枚举1-10人正确便退出,坑爹的是,在poj和hdu都过得代码,uvalive却wa,后来检查,才发现手误打错了一个判断条件,可见poj和hdu的数据有多水!
code:
#include <iostream>
#include <cmath>
#include <cstring>
#include <cstdio>
using namespace std;
typedef long long ll;
ll n;
int ok(int m)   //暴力枚举函数
{
for (int i=0;i<m;i++)
{
if ((n-1)%m!=0)   return 0;
else  n=(n-1)/m*(m-1);
}
if (n%m==0) return 1;
return 0;     //此处误写成1在poj和hdu也能过
}
int main()
{
while (~scanf("%lld",&n))
{
if (n<0) break;
printf("%lld coconuts, ",n);
bool t=true;
ll k=n;
for (int i=100;i>1;i--)
{
if (ok(i)==1)
{
printf("%d people and 1 monkey\n",i);
t=false;
break;
}
else n=k;   //一定不能省
}
if (t) printf("no solution\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: