您的位置:首页 > 其它

poj3255(次短路,好题)

2015-10-23 20:05 369 查看
Roadblocks
Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 10258Accepted: 3662
Description

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the
shortest path. She knows there must be some second-shortest path.

The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤
N ≤ 5000) intersections, conveniently numbered 1..N. Bessie starts at intersection 1, and her friend (the destination) is at intersection
N.

The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if
two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).

Input
Line 1: Two space-separated integers: N and
R

Lines 2..R+1: Each line contains three space-separated integers: A,
B, and D that describe a road that connects intersections A and
B and has length D (1 ≤ D ≤ 5000)
Output
Line 1: The length of the second shortest path between node 1 and node
N
Sample Input
4 4
1 2 100
2 4 200
2 3 250
3 4 100

Sample Output
450

Hint
Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450)

/*
最短路的来源一定是到这个点最短的边再加上u-v这条边,
那么次短路的来源可能是到这个点次短的边再加上u-v这条边或者
到这个点最短的边再加上这条边,所以只要将最短路稍作改变,
最短路中的条件是dist[v]<tmp.dis,则continue,这里改为distsecond[v]<tmp.dis
同时注意初始化distsecond[1]=INF,因为次短路可能是从一出发再回到1,再到终点
*/
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <cmath>
#include <ctime>
#include <vector>
#include <cstdio>
#include <cctype>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define inf -0x3f3f3f3f
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define mem0(a) memset(a,0,sizeof(a))
#define mem1(a) memset(a,-1,sizeof(a))
#define mem(a, b) memset(a, b, sizeof(a))
typedef long long ll;
typedef pair<int,int> PI;
const int maxn=5010;
int distmin[maxn],dist_second[maxn];
vector<PI>G[maxn];
struct qnode{
    int u,dis;
    qnode(int _v=0,int _c=0):u(_v),dis(_c){}
    bool operator <(const qnode &r)const{
        return dis>r.dis;
    }
};

void Dijkstra(int n,int start){
    for(int i=1;i<=n;i++)
        distmin[i]=INF,dist_second[i]=INF;
    priority_queue<qnode>que;
    while(!que.empty()) que.pop();
    distmin[start]=0,dist_second[start]=INF;
    que.push(qnode(start,0));
    qnode tmp;
    while(!que.empty()){    //一停不停维护次大值
        tmp=que.top();
        que.pop();
        int u=tmp.u;
        if(dist_second[u]<tmp.dis)  continue;//这个不是次小
        for(int i=0;i<G[u].size();i++){
            int v=G[u][i].first;
            int cost=G[u][i].second;
            int d=tmp.dis+cost;
            if(distmin[v]>d){
                swap(distmin[v],d);
                que.push(qnode(v,distmin[v]));
            }
            if(dist_second[v]>d&&distmin[v]<d){
                dist_second[v]=d;
                que.push(qnode(v,dist_second[v]));
            }
        }
    }
}

int main(){
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF){
        int u,v,w;
        for(int i=1;i<=n;i++)
            G[i].clear();
        for(int i=1;i<=m;i++){
            scanf("%d%d%d",&u,&v,&w);
            G[u].push_back((PI){v,w});
            G[v].push_back((PI){u,w});
        }
        Dijkstra(n,1);
        printf("%d\n",dist_second
);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: