您的位置:首页 > 其它

poj3169(差分约束)

2015-10-27 09:38 274 查看
Layout
Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 8830Accepted: 4247
Description
Like everyone else, cows like to stand close to their friends when queuing for feed. FJ has N (2 <= N <= 1,000) cows numbered 1..N standing along a straight line waiting for feed. The cows are standing in the same order as they
are numbered, and since they can be rather pushy, it is possible that two or more cows can line up at exactly the same location (that is, if we think of each cow as being located at some coordinate on a number line, then it is possible for two or more cows
to share the same coordinate).

Some cows like each other and want to be within a certain distance of each other in line. Some really dislike each other and want to be separated by at least a certain distance. A list of ML (1 <= ML <= 10,000) constraints describes which cows like each other
and the maximum distance by which they may be separated; a subsequent list of MD constraints (1 <= MD <= 10,000) tells which cows dislike each other and the minimum distance by which they must be separated.

Your job is to compute, if possible, the maximum possible distance between cow 1 and cow N that satisfies the distance constraints.
Input
Line 1: Three space-separated integers: N, ML, and MD.

Lines 2..ML+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at most D (1 <= D <= 1,000,000) apart.

Lines ML+2..ML+MD+1: Each line contains three space-separated positive integers: A, B, and D, with 1 <= A < B <= N. Cows A and B must be at least D (1 <= D <= 1,000,000) apart.
Output
Line 1: A single integer. If no line-up is possible, output -1. If cows 1 and N can be arbitrarily far apart, output -2. Otherwise output the greatest possible distance between cows 1 and N.
Sample Input
4 2 1
1 3 10
2 4 20
2 3 3

Sample Output
27

Hint
Explanation of the sample:

There are 4 cows. Cows #1 and #3 must be no more than 10 units apart, cows #2 and #4 must be no more than 20 units apart, and cows #2 and #3 dislike each other and must be no fewer than 3 units apart.

The best layout, in terms of coordinates on a number line, is to put cow #1 at 0, cow #2 at 7, cow #3 at 10, and cow #4 at 27.
Source
USACO 2005 December Gold

/*poj3169首先题目中的隐含条件是
 d[i] <= d[i + 1] 
即d[i + 1] + 0 >= d[i]
然后对那ML个条件
d[y] - d[x] <= w -> d[x] + w >= d[y]
对那MD个条件
d[y] - d[x] >= w -> d[y] + (-w) >= d[x]
注意spfa的栈不是很稳定,会错*/
#include <map>
#include <set>
#include <stack>
#include <queue>
#include <cmath>
#include <ctime>
#include <vector>
#include <cstdio>
#include <cctype>
#include <cstring>
#include <cstdlib>
#include <iostream>
#include <algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define inf -0x3f3f3f3f
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define mem0(a) memset(a,0,sizeof(a))
#define mem1(a) memset(a,-1,sizeof(a))
#define mem(a, b) memset(a, b, sizeof(a))
typedef long long ll;
typedef pair<int,int> PI;
const int maxn=1010;
int dist[maxn],vis[maxn],cnt[maxn];
vector<PI>G[maxn];

void scan(int ml,int mr){
    int u,v,w;
    for(int i=1;i<=ml;i++){
        scanf("%d%d%d",&u,&v,&w);
        G[u].push_back(PI{v,w});
    }
    for(int i=1;i<=mr;i++){
        scanf("%d%d%d",&u,&v,&w);
        G[v].push_back(PI{u,-w});
    }
}

bool spfa(int start,int n){
    mem0(vis);
    for(int i=1;i<=n;i++)
        dist[i]=INF;
    dist[start]=0;
    vis[start]=1;
    queue<int>que;
    que.push(start);
    mem0(cnt);
    while(!que.empty()){
        int u=que.front();
        que.pop();
        vis[u]=0;
        for(int i=0;i<G[u].size();i++){
            int v=G[u][i].first;
            if(dist[v]>dist[u]+G[u][i].second){
                dist[v]=dist[u]+G[u][i].second;
                if(!vis[v]){
                    vis[v]=true;
                    que.push(v);
                    if(++cnt[v]>n)
                        return false;
                }
            }
        }
    }
    return true;
}

void init(int n){
    for(int i=1;i<=n;i++)
        G[i].clear();
}

int main(){
    int n,ml,mr;
    while(scanf("%d%d%d",&n,&ml,&mr)!=EOF){
        init(n);
        scan(ml,mr);
        for(int i=1;i<n;i++)
        G[i+1].push_back(PI{i,0});
        bool flag=spfa(1,n);
        if(!flag)
            printf("-1\n");
        else if(dist
==INF)
            printf("-2\n");
        else
            printf("%d\n",dist
);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: