您的位置:首页 > 其它

Dijkstra-POJ-1502-MPI Maelstrom

2015-10-14 19:37 363 查看
MPI Maelstrom

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 7182 Accepted: 4375

Description

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee’s research advisor, Jack Swigert, has asked her to benchmark the new system.

Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert.
Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.”

“How is Apollo’s port of the Message Passing Interface (MPI) working out?” Swigert asked.

Not so well,'' Valentine replied.
To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.”

“Is there anything you can do to fix that?”

Yes,'' smiled Valentine.
There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.”

“Ah, so you can do the broadcast as a binary tree!”

“Not really a binary tree – there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don’t necessarily arrive at the destinations at the same time – there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.”

Input

The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100.

The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j.

Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied.

The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output

Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input

5

50

30 5

100 20 50

10 x x 10

Sample Output

35

Source

East Central North America 1996

这真的是一道英语阅读题。。。无力吐槽。

直接求出单元最短路径,然后求出最远的距离输出就是所需时间。

//
//  main.cpp
//  最短路练习-G-MPI maelstrom
//
//  Created by 袁子涵 on 15/10/14.
//  Copyright © 2015年 袁子涵. All rights reserved.
//
//  32ms    812KB

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <stdlib.h>

#define minof(a,b)  ((a)>(b)?(b):(a))
#define maxof(a,b)  ((a)>(b)?(a):(b))
#define INF 999999999
using namespace std;

int n;
long long int map[105][105],dis[105],mins,out;
bool book[105];

void dijkstra()
{
int next=0;
for (int i=0; i<n; i++) {
dis[i]=map[0][i];
}
book[0]=1;
for (int i=0; i<n; i++) {
mins=INF;
for (int j=0; j<n; j++) {
if (mins>dis[j] && book[j]==0) {
mins=dis[j];
next=j;
}
}
book[next]=1;
for (int j=0; j<n; j++) {
if (mins+map[next][j]<dis[j]) {
dis[j]=mins+map[next][j];
}
}
}
}

int main(int argc, const char * argv[]) {
char in1[20];
long long int in2;
memset(book, 0, sizeof(book));
cin >> n;
for (int i=0; i<n; i++) {
for (int j=0; j<i; j++) {
cin >> in1;
if (in1[0]=='x') {
map[i][j]=INF;
map[j][i]=INF;
continue;
}
in2=atoi(in1);
map[i][j]=in2;
map[j][i]=in2;
}
map[i][i]=0;
}
dijkstra();
out=0;
for (int i=0; i<n; i++) {
out=maxof(out, dis[i]);
}
cout << out << endl;
return 0;
}


再次用kb巨的优先队列模板做了一发。

//
//  main.cpp
//  POJ-1502-MPI Maelstrom
//
//  Created by 袁子涵 on 15/11/28.
//  Copyright © 2015年 袁子涵. All rights reserved.
//
//  16ms    804KB

#include <iostream>
#include <string.h>
#include <stdio.h>
#include <math.h>
#include <algorithm>
#include <stdlib.h>
#include <vector>
#include <queue>
#define MAXN 105
#define INF 0x3f3f3f3f
using namespace std;

int n;
struct qnode {
int v,c;
qnode(int _v=0,int _c=0):v(_v),c(_c){}
bool operator <(const qnode &r) const
{
return c>r.c;
}
};
struct Edge
{
int v,cost;
Edge(int _v=0,int _cost=0):v(_v),cost(_cost){}
};
vector<Edge>E[MAXN];
bool vis[MAXN];
int dist[MAXN];
void Dijkstra(int start)
{
memset(vis, 0, sizeof(vis));
for (int i=1; i<=n; i++) {
dist[i]=INF;
}
priority_queue<qnode>que;
while (!que.empty()) {
que.pop();
}
dist[start]=0;
que.push(qnode(start,0));
qnode tmp;
while (!que.empty()) {
tmp=que.top();
que.pop();
int u=tmp.v;
if (vis[u]) {
continue;
}
vis[u]=1;
for (int i=0; i<E[u].size(); i++) {
int v=E[tmp.v][i].v;
int cost=E[u][i].cost;
if (!vis[v]&&dist[v]>dist[u]+cost) {
dist[v]=dist[u]+cost;
que.push(qnode(v,dist[v]));
}
}
}
}
void addedge(int u,int v,int w)
{
E[u].push_back(Edge(v,w));
}
int main(int argc, const char * argv[]) {
char x[20];
cin >> n;
for (int i=1; i<=n; i++) {
E[i].clear();
}
for (int i=1; i<=n; i++) {
for (int j=1; j<i; j++) {
scanf("%s",x);
if (x[0]=='x') {
continue;
}
else
{
int temp=atoi(x);
addedge(i,j,temp);
addedge(j,i,temp);
}
}
}
Dijkstra(1);
int out=0;
for (int i=2; i<=n; i++) {
out=max(out,dist[i]);
}
cout << out << endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: