您的位置:首页 > 其它

hdu 5475 An easy problem 线段树

2015-10-03 18:08 357 查看


An easy problem

Time Limit: 8000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)

Total Submission(s): 746    Accepted Submission(s): 427


Problem Description

One day, a useless calculator was being built by Kuros. Let's assume that number X is showed on the screen of calculator. At first, X = 1. This calculator only supports two types of operation.

1. multiply X with a number.

2. divide X with a number which was multiplied before.

After each operation, please output the number X modulo M.

 

Input

The first line is an integer T(1≤T≤10),
indicating the number of test cases.

For each test case, the first line are two integers Q and M. Q is the number of operations and M is described above. (1≤Q≤105,1≤M≤109)

The next Q lines, each line starts with an integer x indicating the type of operation.

if x is 1, an integer y is given, indicating the number to multiply. (0<y≤109)

if x is 2, an integer n is given. The calculator will divide the number which is multiplied in the nth operation. (the nth operation must be a type 1 operation.)

It's guaranteed that in type 2 operation, there won't be two same n.

 

Output

For each test case, the first line, please output "Case #x:" and x is the id of the test cases starting from 1.

Then Q lines follow, each line please output an answer showed by the calculator.

 

Sample Input

1
10 1000000000
1 2
2 1
1 2
1 10
2 3
2 4
1 6
1 7
1 12
2 7

 

Sample Output

Case #1:
2
1
2
20
10
1
6
42
504
84

 

Source

2015 ACM/ICPC Asia Regional Shanghai Online

用线段树维护区间乘积即可。删除操作就是把数字置为1.

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
#include<vector>
#include<map>
using namespace std;
#define maxn 300007
int M;
int num[maxn],lc[maxn],rc[maxn],cnt;
void build(int u,int l,int r){
num[u] = 1;
if(l == r) return ;
int mid = (l+r)/2;
lc[u] = ++cnt;
rc[u] = ++cnt;
build(lc[u],l,mid);
build(rc[u],mid+1,r);
}

void add(int u,int l,int r,int p,int val){
if(l == r){
num[u] = val;
return ;
}
int mid = (l+r)/2;
if(p > mid) add(rc[u],mid+1,r,p,val);
else add(lc[u],l,mid,p,val);
num[u] = ((long long)num[lc[u]]*num[rc[u]])%M;
}

int main(){
int t,n,tt=1,u,v;
scanf("%d",&t);
while(t--){
scanf("%d%d",&n,&M);
cnt = 0;
build(0,0,n-1);
printf("Case #%d:\n",tt++);
for(int i = 0;i < n; i++){
scanf("%d%d",&u,&v);
if(u == 1)
add(0,0,n-1,i,v);
else
add(0,0,n-1,v-1,1);
printf("%d\n",num[0]%M);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  线段树 hdu