您的位置:首页 > 其它

hdu 5441 Travel 排序 并查集

2015-10-03 18:26 218 查看


Travel

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)

Total Submission(s): 2149    Accepted Submission(s): 740


Problem Description

Jack likes to travel around the world, but he doesn’t like to wait. Now, he is traveling in the Undirected Kingdom. There are n cities
and m bidirectional
roads connecting the cities. Jack hates waiting too long on the bus, but he can rest at every city. Jack can only stand staying on the bus for a limited time and will go berserk after that. Assuming you know the time it takes to go from one city to another
and that the time Jack can stand staying on a bus is x minutes,
how many pairs of city (a,b) are
there that Jack can travel from city a to b without
going berserk?

 

Input

The first line contains one integer T,T≤5,
which represents the number of test case.

For each test case, the first line consists of three integers n,m and q where n≤20000,m≤100000,q≤5000.
The Undirected Kingdom has n cities
and mbidirectional
roads, and there are q queries.

Each of the following m lines
consists of three integers a,b and d where a,b∈{1,...,n} and d≤100000.
It takes Jack d minutes
to travel from city a to
city b and
vice versa.

Then q lines
follow. Each of them is a query consisting of an integer x where x is
the time limit before Jack goes berserk.

 

Output

You should print q lines
for each test case. Each of them contains one integer as the number of pair of cities (a,b) which
Jack may travel from a to b within
the time limit x.

Note that (a,b) and (b,a) are
counted as different pairs and a and b must
be different cities.

 

Sample Input

1
5 5 3
2 3 6334
1 5 15724
3 5 5705
4 3 12382
1 3 21726
6000
10000
13000

 

Sample Output

2
6
12

 

Source

2015 ACM/ICPC Asia Regional Changchun Online

#include<iostream>
#include<cstring>
#include<algorithm>
#include<cstdio>
using namespace std;
#define maxn 1000007
struct Node{
int u,v,d;
bool operator <(const Node & a)const{
return d < a.d;
}
};
Node edge[maxn];
Node query[maxn];
int ans[maxn];
int fa[maxn],num[maxn];
int find(int u){
if(fa[u] == u) return u;
return fa[u]=find(fa[u]);
}

int main(){
int t,n,m,q;
scanf("%d",&t);
while(t--){
scanf("%d%d%d",&n,&m,&q);
for(int i = 0;i < m; i++)
scanf("%d%d%d",&edge[i].u,&edge[i].v,&edge[i].d);
for(int i = 0;i < q; i++){
scanf("%d",&query[i].d);
query[i].u = i;
}
sort(edge,edge+m);
sort(query,query+q);
for(int i = 1;i <= n; i++)
fa[i] = i, num[i] = 1;
int f1,f2,cnt=0,res=0;
for(int i = 0;i < q; i++){
while(cnt < m && edge[cnt].d <= query[i].d){
f1 = find(edge[cnt].u);
f2 = find(edge[cnt].v);
if(f1 != f2){
res += 2*num[f1]*num[f2];
fa[f1] = f2;
num[f2] += num[f1];
}
cnt++;
}
ans[query[i].u] = res;
}
for(int i = 0;i < q; i++)
printf("%d\n",ans[i]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  Travel 排序 并查集 hdu