您的位置:首页 > 大数据 > 人工智能

Light OJ 1138:Trailing Zeroes (III)【二分+求阶乘中某质因子的幂】

2015-09-28 13:56 483 查看
 Trailing Zeroes (III)
Time Limit:2000MS     Memory Limit:32768KB     64bit IO Format:%lld & %llu
Submit Status Practice LightOJ
1138

Appoint description: 
System Crawler  (2015-09-26)

Description

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero
on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5
Case 2: 10
Case 3: impossible
求阶乘N!末尾零的个数:

int numOfZero(int n)
{
int num = 0, i;
for(i=5; i<=n; i*=5)
{
num += n/i;
}
return num;
}AC-code:
#include<cstdio>
long long n;
long long qiu(long long x)
{
long long num=0;
for(long long i=5;i<=x;i*=5)
num+=x/i;
return num;
}
long long solve(long long l,long long r)
{
long long mid=(l+r)/2;
long long tmp=qiu(mid);
if(l==r)
{
if(tmp==n)
return mid;
else
return -1;
}
if(tmp<n)
return solve(mid+1,r);
else if(tmp>n)
return solve(l,mid);
else
return mid;
}
int main()
{
int t,i;
scanf("%d",&t);
for(i=1;i<=t;i++)
{
scanf("%lld",&n);
long long ans=solve(0,1000000000000);
if(ans==-1)
printf("Case %d: impossible\n",i);
else
{
while(qiu(ans-1)==n)
ans--;
printf("Case %d: %lld\n",i,ans);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: