您的位置:首页 > 大数据 > 人工智能

杭电2674N!Again

2015-09-20 13:27 363 查看


N!Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 4152    Accepted Submission(s): 2232


Problem Description

WhereIsHeroFrom:             Zty, what are you doing ?

Zty:                                     I want to calculate N!......

WhereIsHeroFrom:             So easy! How big N is ?

Zty:                                    1 <=N <=1000000000000000000000000000000000000000000000…

WhereIsHeroFrom:             Oh! You must be crazy! Are you Fa Shao?

Zty:                                     No. I haven's finished my saying. I just said I want to calculate N! mod 2009

Hint : 0! = 1, N! = N*(N-1)!

 

Input

Each line will contain one integer N(0 <= N<=10^9). Process to end of file.

 

Output

For each case, output N! mod 2009

 

Sample Input

4
5

 

Sample Output

24
120

 
我记得那时候团队赛,当我写出这个代码时,队友表示不理解,我就笑了一下,那时候还很早,没开始接触算法,甚至c都没有学好。
附代码:
#include<stdio.h>
int main()
{
__int64 i,n,j,k;
while(scanf("%I64d",&n)!=EOF)
{
k=1;
if(n>41)
printf("0\n");
else
{
for(i=1;i<=n;i++)
{
k=k*i;
if(k>2009)
k=k%2009;
}
printf("%I64d\n",k);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电 数论