您的位置:首页 > 大数据 > 人工智能

杭电1023Train Problem II

2015-09-22 13:50 357 查看


Train Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6995    Accepted Submission(s): 3786


Problem Description

As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.

 

Input

The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.

 

Output

For each test case, you should output how many ways that all the trains can get out of the railway.

 

Sample Input

1
2
3
10

 

Sample Output

1
2
5
16796

Hint
The result will be very large, so you may not process it by 32-bit integers.

 
卡特兰数,附送大数卡特兰数模板
附代码:
#include<cstdio>
#include<cstring>
#define N 60
using namespace std;
int main()
{
int h[101][2*N+1],i,j,k,l,n;
memset(h,0,sizeof(h));
h[0][1]=1;h[1][1]=1;
for(i=2;i<=100;i++)
{
for(j=0;j<i;j++)
for(k=1;k<N;k++)
for(l=1;l<N;l++)
h[i][k+l-1]+=h[j][k]*h[i-j-1][l];
for(j=1;j<N;j++)
{
h[i][j+1]+=h[i][j]/10;
h[i][j]%=10;
}
}
while(scanf("%d",&n)!=EOF)
{
i=N;
while(h
[--i]==0);
for(j=i;j>0;j--)
printf("%d",h
[j]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  杭电 卡特兰数