您的位置:首页 > 其它

hdoj 3336 Count the string

2015-09-09 22:22 351 查看

Count the string

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 6627 Accepted Submission(s): 3067



[align=left]Problem Description[/align]
It is well known that AekdyCoin is good at string problems as well as number theory problems. When given a string s, we can write down all the non-empty prefixes of this string. For example:

s: "abab"

The prefixes are: "a", "ab", "aba", "abab"

For each prefix, we can count the times it matches in s. So we can see that prefix "a" matches twice, "ab" matches twice too, "aba" matches once, and "abab" matches once. Now you are asked to calculate the sum of the match times for all the prefixes. For "abab",
it is 2 + 2 + 1 + 1 = 6.

The answer may be very large, so output the answer mod 10007.

[align=left]Input[/align]
The first line is a single integer T, indicating the number of test cases.

For each case, the first line is an integer n (1 <= n <= 200000), which is the length of string s. A line follows giving the string s. The characters in the strings are all lower-case letters.

[align=left]Output[/align]
For each case, output only one number: the sum of the match times for all the prefixes of s mod 10007.

[align=left]Sample Input[/align]

1
4
abab


[align=left]Sample Output[/align]

6
思路:给出一个长度为l的字符串,它有l个前缀,求这个字符串包含这些前缀的总个数。
代码:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<algorithm>
#define M 200000+10
using namespace std;
char s[M];
int p[M],dp[M];
int l;
void getp()
{
int i=0,j=-1;
p[i]=j;
while(i<l)
{
if(j==-1||s[i]==s[j])
{
i++;
j++;
p[i]=j;
}
else
j=p[j];
}
}
int main()
{
int t;
int i;
int cnt;
scanf("%d",&t);
while(t--)
{
scanf("%d",&l);
scanf("%s",s);
getp();
cnt=0;
dp[0]=0;
for(i=1;i<=l;i++)
{
dp[i]=(dp[p[i]]+1)%10007;
cnt=(cnt+dp[i])%10007;
}
printf("%d\n",cnt);
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: