您的位置:首页 > 大数据 > 人工智能

Lightoj 1138 Trailing Zeroes (III) 【二分】

2015-09-22 12:36 549 查看
Description

You task is to find minimal natural number N, so that N! contains exactly Q zeroes on the trail in decimal notation. As you know N! = 1*2*...*N. For example, 5! = 120, 120 contains one zero
on the trail.

Input

Input starts with an integer T (≤ 10000), denoting the number of test cases.

Each case contains an integer Q (1 ≤ Q ≤ 108) in a line.

Output

For each case, print the case number and N. If no solution is found then print 'impossible'.

Sample Input

3

1

2

5

Sample Output

Case 1: 5
Case 2: 10
Case 3: impossible

思路:只有2*5才会出现0,因在阶乘过程中2的个数比5多,所以只要求出阶乘中有多少个因子5即可。

代码:

#include<stdio.h>
long long find(long long x)
{
long long num=0;
while(x)
{
num+=x/5;
x/=5;
}
return num;
}
int main()
{
int t,i;
scanf("%d",&t);
for(i=1;i<=t;i++)
{
int n;
scanf("%d",&n);
printf("Case %d: ",i);
long long l=1;
long long r=1000000000000;
long long mid;
while(l<=r)
{
mid=(l+r)/2;
long long x=find(mid);
if(x>=n)
r=mid-1;
else
l=mid+1;
}
if(find(l)!=n)
printf("impossible\n");
else
printf("%lld\n",l);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: