您的位置:首页 > 其它

九度OJ 题目1141:Financial Management

2015-09-03 17:38 204 查看

一.题目描述:

Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out
what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.

输入:

Each case will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.

输出:

For each case, the output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other
spaces or characters in the output.

样例输入: 100.00

489.12

12454.12

1234.10

823.05

109.20

5.27

1542.25

839.18

83.99

1295.01

1.75

样例输出: $1581.42

二.题目分析

水题

三代码

#include <stdio.h>
#include <stdlib.h>

int main()
{
double x,sum;
int i;

while(scanf("%lf",&x)!=EOF)
{
sum=x;
for(i=1;i<12;i++)
{
scanf("%lf",&x);
sum +=x;
}

printf("$%.2lf\n",sum/12);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: