您的位置:首页 > 大数据 > 人工智能

hdu5319 Painter

2015-08-28 15:37 489 查看
Problem Description
Mr. Hdu is an painter, as we all know, painters need ideas to innovate , one day, he got stuck in rut and the ideas dry up, he took out a drawing board and began to draw casually. Imagine the board is a rectangle, consists of several
square grids. He drew diagonally, so there are two kinds of draws, one is like ‘\’ , the other is like ‘/’. In each draw he choose arbitrary number of grids to draw. He always drew the first kind in red color, and drew the other kind in blue color, when a
grid is drew by both red and blue, it becomes green. A grid will never be drew by the same color more than one time. Now give you the ultimate state of the board, can you calculate the minimum time of draws to reach this state.


Input
The first line is an integer T describe the number of test cases.

Each test case begins with an integer number n describe the number of rows of the drawing board.

Then n lines of string consist of ‘R’ ‘B’ ‘G’ and ‘.’ of the same length. ‘.’ means the grid has not been drawn.

1<=n<=50

The number of column of the rectangle is also less than 50.

Output

Output an integer as described in the problem description.



Output
Output an integer as described in the problem description.


Sample Input
2
4
RR.B
.RG.
.BRR
B..R
4
RRBB
RGGB
BGGR
BBRR




Sample Output
3
6



题意:

一个画师在画板作画。画笔有两种颜色,且只有两种画法,
\
/
,
\
即沿着对角线的方向,同理。
\
只能是红色
R,
/
只能是蓝色 B。如果一个格子被B R个染一次,就变成绿色 G 。初始状态是什么都没有,给一个最终状态的画布,求用最少几笔可以到达该最终状态。

每个格子只能被相同颜色染一次,画家可以选择任意起点作为画笔起点。

每一笔都是连续的。

解答:

题目分析:刚开始做以为得搜索,其实没那么难。从第一行第一个开始,直接按两个方向枚举,\ 这种样子刷,若当前点是红或绿且斜前一个点不是红且不是绿,则必然要刷一次,同理 / 这样刷时也判断一下,可是为什么这样算出来就是最小的呢,因为只在必须要刷的时候才刷,所以显然这样就是最优的

代码:

#include <cstdio>
#include <cstring>
char s[55][55];

int main()
{
    int T;
    scanf("%d", &T);
    while(T--)
    {
        int n;
        scanf("%d", &n);
        for(int i = 1; i <= n; i++)
            scanf("%s", s[i] + 1);
        int m = strlen(s[1] + 1);
        int ans = 0;
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= m; j++)
                if(s[i][j] == 'R' || s[i][j] == 'G')
                    if(!(s[i - 1][j - 1] == 'R' || s[i - 1][j - 1] == 'G'))
                        ans ++;
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= m; j++)
                if(s[i][j] == 'B' || s[i][j] == 'G')
                    if(!(s[i - 1][j + 1] == 'B' || s[i - 1][j + 1] == 'G'))
                        ans ++;
        printf("%d\n", ans);
    }
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: