您的位置:首页 > 产品设计 > UI/UE

HDU 1005 Number Sequence

2015-08-26 07:01 477 查看

Number Sequence

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 129265 Accepted Submission(s): 31474


[align=left]Problem Description[/align]
A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

[align=left]Input[/align]
The
input consists of multiple test cases. Each test case contains 3
integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n
<= 100,000,000). Three zeros signal the end of input and this test
case is not to be processed.

[align=left]Output[/align]
For each test case, print the value of f(n) on a single line.

[align=left]Sample Input[/align]

1 1 3
1 2 10
0 0 0

[align=left]Sample Output[/align]

2
5

[align=left]Author[/align]
CHEN, Shunbao

[align=left]Source[/align]
ZJCPC2004

[align=left]Recommend[/align]
JGShining | We have carefully selected several similar problems for you: 1008 1004 1021 1019 1003

既然模7了结果只有0到6,七种可能,所以猜想是有循环节的,但是不同的a,b循环点不一样。所以自己找一下循环点, 7 7数据特殊结果全是0,单独处理。

#include<queue>
#include<math.h>
#include<stdio.h>
#include<string.h>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
#define N 105
#define INF 0x3f3f3f3f

int a,b,n,mod;
__int64 f
;

int main()
{
f[1]=1;f[2]=1;
while(~scanf("%d%d%d",&a,&b,&n)&&(a+b+n))
{
if(a==7&&b==7)
{
printf("0\n");
continue;
}
for(int i=3;i<=100;i++)
{
f[i]=(a*f[i-1]+b*f[i-2])%7;
if(i>6 && f[i]==f[3] && f[i-1]==1 &&f[i-2]==1)
{
mod=i-3;break;
}
}
n=n%mod;
if(n==0)n=mod;
cout<<f
<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: