您的位置:首页 > 产品设计 > UI/UE

【POJ1417】【True Liars】【加权并查集+背包+输出路径】

2015-08-25 23:56 896 查看
Language:
Default

True Liars

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 2407Accepted: 744
Description

After having drifted about in a small boat for a couple of days, Akira Crusoe Maeda was finally cast ashore on a foggy island. Though he was exhausted and despaired, he was still fortunate to remember a legend of the foggy island, which he had heard from patriarchs
in his childhood. This must be the island in the legend. In the legend, two tribes have inhabited the island, one is divine and the other is devilish, once members of the divine tribe bless you, your future is bright and promising, and your soul will eventually
go to Heaven, in contrast, once members of the devilish tribe curse you, your future is bleak and hopeless, and your soul will eventually fall down to Hell.

In order to prevent the worst-case scenario, Akira should distinguish the devilish from the divine. But how? They looked exactly alike and he could not distinguish one from the other solely by their appearances. He still had his last hope, however. The members
of the divine tribe are truth-tellers, that is, they always tell the truth and those of the devilish tribe are liars, that is, they always tell a lie.

He asked some of them whether or not some are divine. They knew one another very much and always responded to him "faithfully" according to their individual natures (i.e., they always tell the truth or always a lie). He did not dare to ask any other forms of
questions, since the legend says that a devilish member would curse a person forever when he did not like the question. He had another piece of useful informationf the legend tells the populations of both tribes. These numbers in the legend are trustworthy
since everyone living on this island is immortal and none have ever been born at least these millennia.

You are a good computer programmer and so requested to help Akira by writing a program that classifies the inhabitants according to their answers to his inquiries.

Input

The input consists of multiple data sets, each in the following format :

n p1 p2

xl yl a1

x2 y2 a2

...

xi yi ai

...

xn yn an

The first line has three non-negative integers n, p1, and p2. n is the number of questions Akira asked. pl and p2 are the populations of the divine and devilish tribes, respectively, in the legend. Each of the following n lines has two integers xi, yi and one
word ai. xi and yi are the identification numbers of inhabitants, each of which is between 1 and p1 + p2, inclusive. ai is either yes, if the inhabitant xi said that the inhabitant yi was a member of the divine tribe, or no, otherwise. Note that xi and yi
can be the same number since "are you a member of the divine tribe?" is a valid question. Note also that two lines may have the same x's and y's since Akira was very upset and might have asked the same question to the same one more than once.

You may assume that n is less than 1000 and that p1 and p2 are less than 300. A line with three zeros, i.e., 0 0 0, represents the end of the input. You can assume that each data set is consistent and no contradictory answers are included.

Output

For each data set, if it includes sufficient information to classify all the inhabitants, print the identification numbers of all the divine ones in ascending order, one in a line. In addition, following the output numbers, print end in a line. Otherwise, i.e.,
if a given data set does not include sufficient information to identify all the divine members, print no in a line.
Sample Input
2 1 1
1 2 no
2 1 no
3 2 1
1 1 yes
2 2 yes
3 3 yes
2 2 1
1 2 yes
2 3 no
5 4 3
1 2 yes
1 3 no
4 5 yes
5 6 yes
6 7 no
0 0 0

Sample Output
no
no
1
2
end
3
4
5
6
end

Source

Japan 2002 Kanazawa
[Submit] [Go Back] [Status]
[Discuss]

#include <iostream>
#include <cstring>
#include <cmath>
#include <queue>
#include <stack>
#include <list>
#include <map>
#include <set>
#include <string>
#include <cstdlib>
#include <cstdio>
#include <algorithm>
using namespace std;
    
#define rep(i,a,n) for (int i=a;i<n;i++)
#define per(i,a,n) for (int i=n-1;i>=a;i--)
#define mp push_back

int n,p1,p2;
char str[5];
int F[610];
int val[610];
int cnt;
int a[610][2]; //0: 1:
vector<int> b[610][2];
int dp[610][610]; //用了i个物品,好人数目为j的方案数目
int pre[610][610];
bool used[610];

int Find(int x)
{
	if(F[x] == -1) return x;
	int t = Find(F[x]);
	val[x] ^= val[F[x]];
	return F[x] = t;
}

void merge(int x,int y,int op)
{
	int fx = Find(x);
	int fy = Find(y);
	if(fx != fy)
	{
		F[fx] = fy;
		val[fx] = val[x]^val[y]^op;
	}
}
int main()
{
    while(scanf("%d%d%d",&n,&p1,&p2))
	{
		if(n == 0 && p1 == 0 && p2 == 0) break;
		memset(F,-1,sizeof(F));
		memset(val,0,sizeof(val));
		bool ok = true;
		cnt = 1;
		for(int i=0;i<n;i++)
		{
			int u,v,op;
			scanf("%d%d%s",&u,&v,str);
			if(!ok) continue;
			op = (str[0] == 'y' ? 0 : 1);
			int t1 = Find(u);
			int t2 = Find(v);
			if(t1 == t2)
			{
			}
			else
			{
				merge(u,v,op);
			}
		}
		if(!ok)
		{
			printf("no\n");
			continue;
		}
		
		for(int i=0;i<=p1+p2;i++)
		{
			a[i][0] = 0;
			a[i][1] = 0;
			b[i][0].clear();
			b[i][1].clear();
		}
		
		memset(used,0,sizeof(used));
		for(int i=1;i<=p1+p2;i++)
		{
			if(used[i]) continue;
			int tmp = Find(i);
			for(int j=1;j<=p1+p2;j++)
			{
				if(tmp == Find(j) && !used[j])
				{
					used[j] = true;
					a[cnt][val[j]] ++;
					b[cnt][val[j]].push_back(j);
				}
			}
			cnt ++;
		}
	
		memset(dp,0,sizeof(dp));
		memset(pre,-1,sizeof(pre));
		dp[0][0] = 1;
		for(int i=1;i<cnt;i++)
		{
			for(int j=p1;j>=0;j--)
			{
				if(j >= a[i][0]  && dp[i-1][j-a[i][0]])
				{
					dp[i][j] += dp[i-1][j-a[i][0]];
					pre[i][j] = j-a[i][0];

				}
				if(j >= a[i][1] && dp[i-1][j-a[i][1]])
				{
					dp[i][j] += dp[i-1][j-a[i][1]];
					pre[i][j] = j-a[i][1];
				}
			}
		}
		if(dp[cnt-1][p1] != 1)
		{
			printf("no\n");
		}
		else
		{
			vector<int> ans;
			ans.clear();
			int v = p1;
			for(int i=cnt-1;i>=1;i--)
			{
				int nextv = pre[i][v];
				int usedv = v - nextv;
				if(usedv == a[i][0])
				{
					for(int j=0;j<a[i][0];j++)
					{
						ans.push_back(b[i][0][j]);
					}
				}
				else
				{
					for(int j=0;j<a[i][1];j++)
					{
						ans.push_back(b[i][1][j]);
					}
				}
				v = nextv;
			}
			sort(ans.begin(),ans.end());
			for(int i=0;i<ans.size();i++)
			{
				printf("%d\n",ans[i]);
			}

			printf("end\n");

		}

	}
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: