您的位置:首页 > 其它

POJ 2239--Selecting Courses【二分图 && 最大匹配数 && 水题】

2015-08-26 18:59 369 查看
Selecting Courses

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 9363Accepted: 4164
Description

It is well known that it is not easy to select courses in the college, for there is usually conflict among the time of the courses. Li Ming is a student who loves study every much, and at the beginning of each term, he always wants to select courses as more
as possible. Of course there should be no conflict among the courses he selects.

There are 12 classes every day, and 7 days every week. There are hundreds of courses in the college, and teaching a course needs one class each week. To give students more convenience, though teaching a course needs only one class, a course will be taught several
times in a week. For example, a course may be taught both at the 7-th class on Tuesday and 12-th class on Wednesday, you should assume that there is no difference between the two classes, and that students can select any class to go. At the different weeks,
a student can even go to different class as his wish. Because there are so many courses in the college, selecting courses is not an easy job for Li Ming. As his good friends, can you help him?

Input

The input contains several cases. For each case, the first line contains an integer n (1 <= n <= 300), the number of courses in Li Ming's college. The following n lines represent n different courses. In each line, the first number is an integer t (1 <= t <=
7*12), the different time when students can go to study the course. Then come t pairs of integers p (1 <= p <= 7) and q (1 <= q <= 12), which mean that the course will be taught at the q-th class on the p-th day of a week.
Output

For each test case, output one integer, which is the maximum number of courses Li Ming can select.
Sample Input
5
1 1 1
2 1 1 2 2
1 2 2
2 3 2 3 3
1 3 3

Sample Output
4


题意:

在大学里有许许多多的课程,现在小明需要去选择课程,他是一个爱学习的人,所以想尽可能多的选择课程,在学校里有n个课程,并且在学校规定,每周里的每天有12节课,那么一周就有7*12节课。输入第一行为n,代表有n个课程接下来n行,每行第一个数字x代表这个课程在这一周里面需要上x次。然后跟着x对数字,第一个D代表这周的哪一天,第二个C代表这天的哪一节课如果几个课程都在那d天的那c节课上课,那么你需要选择其中的一个,而不能选择多个课程现在要求算出小明最多可以选择多少个课程。

解析:我们把这一周的12 * 7节课编上号,每门课程和对应的节数建边,匈牙利算法求最大匹配数即可,水题一个。

#include <cstdio>
#include <cstring>
#include <algorithm>
#define maxn 330
using namespace std;
int n, m;

int map[maxn][maxn];
int used[maxn];
int link[maxn];

void init(){
    memset(map, 0, sizeof(map));
}

void getmap(){
    for(int i = 1; i <= n; ++i){
        int k;
        scanf("%d", &k);
        while(k--){
            int a, b;
            scanf("%d%d", &a, &b);
            map[i][(a - 1) * 12 + b] = 1;
        }
    }
}

bool dfs(int x){
    for(int i = 1; i <= 7 * 12; ++i){
        if(map[x][i] && !used[i]){
            used[i] = 1;
            if(link[i] == -1 || dfs(link[i])){
                link[i] = x;
                return true;
            }
        }
    }
    return false;
}

int hungary(){
    int ans = 0;
    memset(link, -1, sizeof(link));
    for(int i = 1; i <= n; ++i){
        memset(used, 0, sizeof(used));
        if(dfs(i))
            ans++;
    }
    return ans;
}

int main (){
    while(scanf("%d", &n) != EOF){
        init();
        getmap();
        int sum = hungary();
        printf("%d\n", sum);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: