您的位置:首页 > 其它

poj2388Who's in the Middle【堆排序】

2015-08-19 00:20 204 查看
Language:
Default

Who's in the Middle

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 35209 Accepted: 20554
Description

FJ is surveying his herd to find the most average cow. He wants to know how much milk this 'median' cow gives: half of the cows give as much or more than the median; half give as much or less. 

Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.

Input

* Line 1: A single integer N 

* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.

Output

* Line 1: A single integer that is the median milk output.

Sample Input
5
2
4
1
3
5


Sample Output
3


Hint

INPUT DETAILS: 

Five cows with milk outputs of 1..5 

OUTPUT DETAILS: 

1 and 2 are below 3; 4 and 5 are above 3.

Source

USACO 2004 November
求中位数

#include<cstdio>
#include<cstdlib>
#include<cstring>
using namespace std;
int A[10010];
int size;
void swap(int *a,int *b){
int t;
t=*a;
*a=*b;
*b=t;
}
void HeapAdjust(int i,int num){
int lson=i<<1;
int rson=(i<<1)+1;
int max=i;
if(i<=size/2){
if(lson<=num&&A[lson]>A[max]){
max=lson;
}
if(rson<=num&&A[rson]>A[max]){
max=rson;
}
if(max!=i){
swap(&A[i],&A[max]);
HeapAdjust(max,num);
}
}

}
void BuildHeap(){
for(int i=size>>1;i>=1;--i){
HeapAdjust(i,size);
}
}
void Heapsort(){
BuildHeap();
for(int i=size;i>=1;--i){
swap(&A[1],&A[i]);
HeapAdjust(1,i-1);
}
}
int main()
{
int i;
while(scanf("%d",&size)!=EOF){
for(i=1;i<=size;++i){
scanf("%d",&A[i]);
}
Heapsort();
printf("%d\n",A[size/2+1]);
}
return 0;
}


 

 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  poj2388Whos in the M