您的位置:首页 > 产品设计 > UI/UE

HDU 1005.Number Sequence【很多问题是不能直接求的】【8月15】

2015-08-15 22:10 495 查看
Number Sequence

Problem Description

A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.

Sample Input

1 1 3
1 2 10
0 0 0


Sample Output

2
5


f[1]=f[2]=1;f
=(A*f[n-1]+B*f[n-2])%7;给定A,B,n,求f


不能直接求,不然肯定超时超内存。寻找循环。f[1]=1,f[2]=1;当连续出现两个1的时候就说明是循环了。代码如下:

#include<cstdio>
int main(){
int a,b,n,f[11000];
f[1]=1;f[2]=1;
while(scanf("%d%d%d",&a,&b,&n)!=EOF,a||b||n){
int i;
for(i=3;i<11000;i++){
f[i]=(a*f[i-1]+b*f[i-2])%7;
if(f[i]==1&&f[i-1]==1)//i-2就是循环长度
break;
}
f[0]=f[i-2];
printf("%d\n",f[n%(i-2)]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: